[Samba] Error messages while managing groups in User Manager

kissg mail.gery at gmail.com
Wed Jun 25 20:45:11 GMT 2008

I still haven't found any solution. Have anyone of you ever had this

I also tried it with tdbsam backend, and I got the same error, so it's not
an LDAP-related issue. I have upgraded to Samba version 3.0.30, but the
problem still exists.

Please help, I'm out of ideas!

My original message was:

I recently set up a PDC using Samba version 3.0.28a. According to the
official Samba documentation, I should be able to use the Microsoft User
Manager tool to manage my Samba domain controller. I am able to
add/delete/modify user accounts with no problem, but editing groups is not
possible for some reason. For example, if I try to add a user account to a
group, I get an "Access denied" error message. This sounds a bit strange to
me, since I log in to the domain as root, so privilege problems should not

Is this a bug or have I misconfigured something?

What I have already done:

- Install Samba from package
- Edit smb.conf to suit my needs
- Create basic group mapping with the correct RIDs (512 for domain admins,
513 for users, 514 for guests)
- Create a separated directory structure for all the shares

My shares are located on separate partitions, each have the user_xattr
option enabled in /etc/fstab.

I attached my smb.conf file to this message, to make it easier to understand
my configuration.

Thanks for you help in advance!

More information about the samba mailing list