[Samba] Notification changes sometimes works, sometimes no

Paolo Minazzi paolo.minazzi at gmail.com
Mon Jun 16 09:44:12 GMT 2008

I have compiled samba 3.0.28 and 3.0.30 under both ARM and x86.
I have enabled inotify into the kernel.
I use kernel for both ARM and x86.
I see a strange problem about notification changes. Sometimes
automatic notify works,
sometimes not.

Now I will show who reproduce the error I see.
I have installed SAMBA on

I open an explorer window and I insert "\\".
A window with USER and PASSWORD appears.
I insert user and password, and my share called "RootDisk" apperars.
A click on "RootDisk", and I can use my share. It works OK, and also the
notification is OK. I can create files and remove then, and I have the
automatic update.

Now I close my explorer window.
I open a new explorer windows.
I enter "\\".
I click on "RootDisk".
Now, If I create or remove files, then notification does NOT works !
I have to press F5 key.

Now I close the explorer window.
I open a new explorer window.
I enter "\\\RootDisk".
Now I create and remove files, and the notification works OK.


I underline that I exec PHASE1, then PHASE2, then PHASE3 in this order.
PHASE1 and PHASE3 works OK, PHASE2 does not work OK.

I have tried to insert some debug messages in source/smbd/notify_inotify.c but
I have not understood the difference when notification works OK and
when there is the notification problem.
Inotify support is OK (I have added debug messages and I see them). I
think there is something strange in the communication

I think my smbd.conf is very simple.

I have tried to add some config option
-> socket options = TCP_NODELAY
but this does not solve my problem.

Is this a known error ? or do I make some error ? or is my config incomplete ?

Thanks in advance
Paolo Minazzi

More information about the samba mailing list