[Samba] Switching form NT PDC to AD

Leslie Hartman lphartm at nsa.gov
Fri Jun 13 18:20:00 GMT 2008

I set up a test machine running Red Hat 5.2 and samba version 3.0.28.

We have a unix server sharing out a file system.

The windows users accessed the file system via Samba and as
they all had unix accounts they were just mapped to their UNIX id.
As long as we had groups with the same name, the groups were
mapped as well.

Since going to AD, we would like to do the same thing, but it
appears that the groups aren't mapping.

When I first set it up I had the nsswitch.conf file configured
with files compat winbind. This seemed to be working fine,
but the mapping was going to a new id when we wanted them
to get their unix id, so I swithced the nsswitch.conf file to just
files and compat.

Things seemed to be working until I tried to access a directory
owened by someone else and it wouldn't let me in even though
we were in the same group. It seems like group mapping isn't
taking place. I tested it from the linux side and everything worked
as expected.

If you need any additional information let me know. We are on
a private network so I have to retype anything you wish to see.

Thanks for your help.

More information about the samba mailing list