[Samba] problem upgrading 3.0.23->3.0.26

Linda W samba at tlinx.org
Wed Jul 30 20:33:14 GMT 2008

Helmut Hullen wrote:
> Hallo, Linda,
> The actual version is 3.0.31 - I had some trouble with versions below  
> 3.0.29 (and much trouble with 3.0.23 ...)
> Viele Gruesse!
> Helmut
	Hallo Helmut!

	Thanks for the info...maybe my sup^h^h^hrepository is not as up-to-date
as it should be.  I've no problem upgrading to new ver...I could try installing
the samba from SuSE11, but  SuSE is bad about adding excess package dependencies.
They tend to make one package dependent on "the world" (hyperbole)....so upgrading
to samba from suse11...well lets see what it says...

Yup (**I feel a rant coming on...warning...sanity in question**):

share/suse11/i586# rpm -Uhv --test samba-3.2.0-22.1.i586.rpm 
error: Failed dependencies:
         liblber-2.4.so.2 is needed by samba-3.2.0-22.1.i586
         libldap-2.4.so.2 is needed by samba-3.2.0-22.1.i586
         libtalloc.so.1 is needed by samba-3.2.0-22.1.i586
         libtalloc.so.1(TALLOC_1.2) is needed by samba-3.2.0-22.1.i586
         libtdb.so.1 is needed by samba-3.2.0-22.1.i586
         libtdb.so.1(TDB_1.1) is needed by samba-3.2.0-22.1.i586
         libwbclient.so.0 is needed by samba-3.2.0-22.1.i586
         libwbclient.so.0(WBCLIENT_0.1) is needed by samba-3.2.0-22.1.i586
         liblber-2.4.so.2 is needed by samba-client-3.2.0-22.1.i586
         libldap-2.4.so.2 is needed by samba-client-3.2.0-22.1.i586
         libtalloc.so.1 is needed by samba-client-3.2.0-22.1.i586
         libtalloc.so.1(TALLOC_1.2) is needed by samba-client-3.2.0-22.1.i586
         libtdb.so.1 is needed by samba-client-3.2.0-22.1.i586
         libtdb.so.1(TDB_1.1) is needed by samba-client-3.2.0-22.1.i586
         libwbclient.so.0 is needed by samba-client-3.2.0-22.1.i586
         libwbclient.so.0(WBCLIENT_0.1) is needed by samba-client-3.2.0-22.1.i586

They are pretty bad about handling dependencies to allow packages to be
portable between releases -- no belief in changing "1 thing" at a time...(poor
engineering in my personal opinion)...

Example: I don't use ldap (yet), so why should I care about ldap updates --
they should be packaged separately so parts I don't use won't force other
packages to be updated.

Windows has linux beaten hands down in this area.  Unneeded functions are in
NON-loaded DLL's, and if you don't use that function, you don't need the DLL.
Lack of a non-used DLL won't cause a fatal load error -- but in linux, run-time
linking (vs. load-time) is rarely done.

	Most of those I can upgrade to suse11...but when I get to liblber and libldap
(the ones I DONT USE!!!)...everything complains about an update attempt:
share/suse11# grp liblber *.txt
(files in openldap2-client, so try to upgrade that...and get:...)
hare/suse11# rpm -Uhv i586/openldap2-client-2.4.9-7.1.i586.rpm
error: Failed dependencies:
         liblber-2.3.so.0 is needed by (installed) autofs-5.0.2-30.i586
         liblber-2.3.so.0 is needed by (installed) lighttpd-1.4.17-11.i586
         liblber-2.3.so.0 is needed by (installed) dhcp-server-3.0.6-24.i586
         liblber-2.3.so.0 is needed by (installed) ldapcpplib-0.0.4-96.i586
         liblber-2.3.so.0 is needed by (installed) libsmbclient-3.0.26a-3.i586
         liblber-2.3.so.0 is needed by (installed) pwdutils-3.1.4-27.i586
         liblber-2.3.so.0 is needed by (installed) pwlib-1.10.7-61.i586
         liblber-2.3.so.0 is needed by (installed) sendmail-8.14.1-53.i586
         liblber-2.3.so.0 is needed by (installed) squid-beta-3.0-351.i586
         liblber-2.3.so.0 is needed by (installed) rmail-8.14.1-53.i586
         liblber-2.3.so.0 is needed by (installed) dirmngr-1.0.0-19.i586
         liblber-2.3.so.0 is needed by (installed) samba-client-3.0.26a-3.i586
         liblber-2.3.so.0 is needed by (installed) samba-3.0.26a-3.i586
         libldap-2.3.so.0 is needed by (installed) nfsidmap-0.20-21.i586
         libldap-2.3.so.0 is needed by (installed) lighttpd-1.4.17-11.i586
         libldap-2.3.so.0 is needed by (installed) dhcp-server-3.0.6-24.i586
         libldap-2.3.so.0 is needed by (installed) ldapcpplib-0.0.4-96.i586
         libldap-2.3.so.0 is needed by (installed) libsmbclient-3.0.26a-3.i586
         libldap-2.3.so.0 is needed by (installed) pwdutils-3.1.4-27.i586
         libldap-2.3.so.0 is needed by (installed) pwlib-1.10.7-61.i586
         libldap-2.3.so.0 is needed by (installed) sendmail-8.14.1-53.i586
         libldap-2.3.so.0 is needed by (installed) squid-beta-3.0-351.i586
         libldap-2.3.so.0 is needed by (installed) sudo-1.6.9p2-23.i586
         libldap-2.3.so.0 is needed by (installed) gpg2-2.0.4-49.i586
         libldap-2.3.so.0 is needed by (installed) rmail-8.14.1-53.i586
         libldap-2.3.so.0 is needed by (installed) dirmngr-1.0.0-19.i586
         libldap-2.3.so.0 is needed by (installed) samba-client-3.0.26a-3.i586
         libldap-2.3.so.0 is needed by (installed) samba-3.0.26a-3.i586
         libldap_r-2.3.so.0 is needed by (installed) autofs-5.0.2-30.i586
         libldap_r-2.3.so.0 is needed by (installed) pwlib-1.10.7-61.i586
	All for libraries and functions that I don't use -- completely WORTHLESS.
This is what I mean by bad engineering -- lib ldap should be a run-time library that
is loaded as it is used -- and if I don't use ldap, it wouldn't try to load it and
it wouldn't give me fatal errors.  I don't know how many of the above would fail on
initial load or randomly during usage -- but from experience, such dependencies 
may quite
often cause the util or tool to just "not load" at all because of a load-time 
failure for
an unneeded function!

	So far, I haven't had any luck in explaining to anyone at SuSE who might care,
why this is "bad" or poor practice.  (My persuasive skills in such situations are
sorely lacking...)...



More information about the samba mailing list