[Samba] samba disregarding lock of files

André Moreira amoreira at joint-action.pt
Wed Jul 30 17:01:08 GMT 2008

Hello all,

I'm having a very strange problem with Samba.

I have a PC running the samba server and a PC running the client. On both
PC's I am running the same application where I want some file access to be
blocked if any of the applications is using it. Good idea right?

I'm using fcntl to set and get the lock status of the files as is well
documented in a gazzilion pages about locking files. The files are locked
for writing and reading.

The strange part is that when I run two instances of the application on the
same PC, the files get locked and the applications can get the lock status
of the files, but when I run the applications through samba, the locks
simply seem to be disregarded. The file is opened (as if it wasn't locked),
and I can edit it, but when I try to close the file... only then I get a
message telling me that the file is locked!

I'm running both applications on Linux. The samba server is running with
oplocks = no (so no file caching SHOULD be happening) and locking=yes.

I actually have no idea of what is going on!

Any insight?


More information about the samba mailing list