[Samba] winbindd high CPU usage

Franky Van Liedekerke liedekef at telenet.be
Wed Jul 9 08:31:41 GMT 2008


I'm using squid+samba/winbindd to do proxy authentication for a AD domain.
Using samba 3.0.29 this was working fine.
This week I saw 3.2 was released stable, so I decided to upgrade. The
compile (using solaris 8, 64bit, gcc 3.4.6) went well and I copied the
secrets.tdb to the new version, so I wouldn't need to rejoin the domain.
After this starting samba also succeeded, "wbinfo -t" and all worked just
fine. Even using the ntlm_auth binary worked ok to authenticate a user. So I
thought it to be safe to switch squid to the new version.
But about 2 minutes after squid is started to use the ntlm_auth binary from
the new samba, winbindd is starting to use 99% of the cpu (and this was not
the case in 3.0.29).
Here is my samba config:

security = ADS
workgroup = XXXX
realm = XXXX.BE
winbind separator = +
encrypt passwords = true
winbind use default domain = yes
winbind enum users = no
winbind enum groups = no

Has anybody else seen behaviour like this? Or any clue on how to resolve
this (maybe some new winbindd settings)?


More information about the samba mailing list