[Samba] file differences when copying files to linux, using samba

jeffunit jeff at jeffunit.com
Sat Jan 26 16:53:36 GMT 2008

I have a backup file server running linux and samba 3.0.25b
I have four sata hard drives configured as a software raid 5 array.
I have a client machine running windows xp pro sp2, with all the patches.
I have configured samba, and copied all my files to my backup file server,
using the windows explorer, and 'copy' and 'paste'.

I also wrote a python program that computes the md5sum for all files 
in a directory,
and writes out a file per directory with that info.

After I copied a directory tree containing 255gb of files, I ran 
'diff --recursive'
on the windows tree and the samba tree (from windows).
There were roughly 100 differences reported.

I ran my python program locally on the linux system, and it reported 
that roughly
100 md5sums for files differed.

I have looked at the samba logs, and noticed nothing interesting.
I looked at the status of the raid array, and it is ok.
I ran smartmontools, and all the hard drives have no problems.

Any ideas how to track down this problem?


My network is gigabit ethernet, with intel on-motherboard ethernet nics on both

I don't know what to do to track down this problem.
Any pointers would be appreciated.

More information about the samba mailing list