[Samba] Need help with SWAT

Ryan Novosielski novosirj at umdnj.edu
Wed Jan 9 16:36:01 GMT 2008

Hash: SHA1

Please keep replies on-list, for various reasons.

What message do you get after a telnet to port 901? Always give
messages. For example, can't connect could mean "connection refused" or
"connection timed out" -- completely different problems. Provide ALL
information if you want a good answer. Sometimes folks will think they
can help, but can't be bothered to draw this information out and will
ignore the message.

If it is running via inetd, you should not expect to see swat. Look for
messages in your syslog/messages file. Look at the documentation for
SWAT to see if there is a debug mode to launch it in (probably an option
you'd throw in inetd). inetd does not require a reboot, just a kill
- -HUP/kill -1 or on some platforms inetd -c. There are other ways.

Make sure SWAT is listening on It may be listening only on
your machine's public interface.

Some things to start you off. Others can chime in (provided the replies
stay on-list!) :)

Donald Woeltje wrote:
> Just one system. No other systems. Swat is installed on the same
> system that is running samba. I'm just trying to use the web browser
> on that system to go to http://localhost:901/ or
> http://<ipaddress>:901/ and I'm unable to get into swat. With swat
> supposed to be started by inetd, with the correct entry in the
> inetd.conf file, I would think that all I'd need to do is reboot and
> inetd should start swat. But if I do a ps -A and look through the
> list, swat isn't running. So, let's say that inetd doesn't start swat
> until a call is made to tcp port 901. That being the case, when I try
> to connect with telnet or the web browser, inetd should start swat
> and I should get a response. But I don't. I even tried starting swat
> manually (I'm used to the Windows environment, where I can start
> applications or services manually) but maybe that's not possible to
> do because when I tried it, it just sat there and sat there and sat
> there and then it finally said, "Alarm clock" and went back to a
> console prompt.
> Maybe there a re library files that it needs, to be able to run, and
> even though they may be on my system, it's not able to locate them,
> so it can't start? I know I had that problem when I installed KDE and
> tried to start it from the dtlogin screen. Then someone gave me some
> commands to put into the startkde file, for debugging purposes (the
> debugging output went into a log file), and I was able to find out
> what library files were missing, one by one, until I had them all
> installed and KDE started working. I don't know if that could be the
> same issue here.....and I don't even know how to go about checking to
> see if that is the problem.
> -----Original Message----- From: Ryan Novosielski
> [mailto:novosirj at umdnj.edu] Sent: Tuesday, January 08, 2008 23:01 To:
> Donald Woeltje Cc: samba at lists.samba.org Subject: Re: [Samba] Need
> help with SWAT
> Donald Woeltje wrote:
>> No matter what I try, I cannot get SWAT to work. No, I'm new to 
>> solaris, so maybe I'm not doing something that should be done prior
>> to trying to use SWAT. Samba does seem to be working, somewhat. I
>> can connect to a share using the smbclient on the same solaris
>> system that I installed samba on....but I cannot connect to the
>> share on the solaris system with my Windows XP system. Since it is
>> part of a domain, it's possible that the sysadmins may have some
>> sort of AD policy in affect that is preventing me from connecting
>> to the solaris system's Windows-compatible resources. So, until I
>> try at home, I can't say definitively that Windows to Samba
>> functionality isn't working at all. It just isn't working from my
>> Windows client to my Solaris Samba network shares. But the
>> smbclient program does connect to the shares successfully.
>> But no matter what I do, I cannot get SWAT to work. I've read the 
>> FAQ's and HOWTO's; I can't find anything on troubleshooting SWAT 
>> problems. Maybe I don't have inetd setup properly? Or maybe there
>> is something else I've missed.
>> I could really use some help.
> Can't get SWAT to work is very non-specific. It does not tell me what
> to say for you to lead off with. You need to try the standard UNIX
> tests (telnet to the port it's supposed to be running on, etc.) and
> see what exactly is not happening.

- --
 ---- _  _ _  _ ___  _  _  _
 |Y#| |  | |\/| |  \ |\ |  | |Ryan Novosielski - Systems Programmer II
 |$&| |__| |  | |__/ | \| _| |novosirj at umdnj.edu - 973/972.0922 (2-0922)
 \__/ Univ. of Med. and Dent.|IST/AST - NJMS Medical Science Bldg - C630
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the samba mailing list