[Samba] DFS

Papp Tamás tompos at martos.bme.hu
Wed Jan 9 13:55:19 GMT 2008

Dear All,

I had a working solution on a Redhat EL 4 or 5 or something like that (I 
don't remember exactly).
I changed it to CentOS 5, and now the same config is not working on the 
right way.

I see this on a windows map driver (I haven't tried it with linux):


So the first directory on the share get doubled, the real path should be 
(and was before) W:\Install\Windows\bla\salala .

The mpost interesting thing is that it doesn't happen always. This is, 
how I made the DFS links:

msdfs:\Install -> install (before the reinstall it was

msdfs:\\\Install -> Install, and worked, but now does not matter).

I stucked, I don't see any interesting related to this on the logs.

Could anybody give me some hints, or any help.
Has anybody seen behaviour, like this?

It would be really important for us, but I have no idea.

Version 3.0.25b-1.el5_1.4


        server string = Cluster gateway (SAMBA server)
        passdb backend = tdbsam
        username map = /etc/samba/smbusers
        log file = /var/log/samba/%m.log
        max log size = 50
        load printers = No
        preferred master = No
        wins server =
        hosts allow = 192.168.0.
        block size = 16384
        kernel change notify = No
        write cache size = 16777216
        cups options = raw

        path = /mnt/lustre
        valid users = user
        read only = No
        guest ok = Yes
        oplocks = No
        level2 oplocks = No

        path = /dfs
        read only = No
        guest ok = Yes
        msdfs root = Yes

There is only one user (called 'user').

Thank you very much,


More information about the samba mailing list