[Samba] LDAP problem

tanguy.leost at free.fr tanguy.leost at free.fr
Mon Jan 7 10:41:00 GMT 2008

Selon Rune Tønnesen <rune at tonnesen.org>:

> Hello to you
> I've had the same problem on my old suse linux enterprise server 9, shutdown
> due to
> powerissue.
> I got the same errors from workstations (windows XP).
> My problem was that corruption of openldaps databasefiles (Berkeley) had
> occured.
> I've solved my problem by using the openldap database recovery tools to do a
> manual
> recover.
> http://www.google.co.uk/search?hl=en&q=openldap+recover&meta=
> Secondly some journaled filesystems aren't good at recovering corrupted files
> like
> berkeley databases due powerfailure.
> This problem occur if you enable use of diskcache on your harddrive without a
> UPS,
> get one for your one safety and jobsecurity, it just have to be big enough to
> shutdown the server in a prober way.
> --
> Rune Tønnesen
> Venlig Hilsen/Best Regards


Can anyone help me? I have trouble even finding out what's wrong.
Here is what I get this morning:

- *some* windows clients manage to connect to the domain (very few of them,

- If I run:
smbclient -L \\pdc -U tleost
as root on the PDC server, it asks for my password and shows me the samba
I need to know: is this an evidence that smb+ldap are working fine?

- I still get the same error messages as the ones I described in my previous

- The network *seems* to work fine (clients can access the database servers, for

Thanks in advance for your help

More information about the samba mailing list