[Samba] Another Uploading Printer drivers problem.

Richard Chapman rchapman at aardvark.com.au
Sat Jan 5 06:22:54 GMT 2008

Hi again Willy, Dale and Ryan

You were all right about everything. I have made quite a bit of progress 
- mainly in understanding - but still have problems....

Firstly - Ryan was right - that I completely misunderstood the "Client 
Driver" versus "Server Driver" issue.
You were also right - that I was attempting the upload incorrectly - and 
the method suggested by Willy behaves very differently.

One difficulty I have is that I am using a workgroup rather than domain 
- and this seems to confuse many of the permissions issues. I don't 
really understand how the windows, smaba and linux users relate to each 
other. This makes it a little difficult to compare our smb.conf files. 
Still - let me tell you what I have done - and the problems I still 
have. I have been mainly following Dale's suggested link:

Firstly - My Windows username is rhc - and my linux username is richard 
just to confuse the issue. (Don't ask why - but I will blame 
microsoft.... They wouldn't let me have the same username as machine 
name..).  But I have defined a samba to unix user mapping. I have also 
created a linux user rhc with the same password as the windows user. I 
have defined a group mtadmin - and set it as the secondary group for 
both richard and rhc.

I have defined the print$ share thus:
    comment = Windows Printer Driver Share
    path = /var/lib/samba/drivers
        write list = root, @ntadmin, richard, rhc
        admin users = root, @ntadmin, richard, rhc

I note that Dale suggested the last line whereas the blog suggested:
    print admin =

I have tried both.

Problem 1:
When I go to \\server\print$
It correctly displays the 8 empty sub folders. However - if  try to 
create a "New Folder" in the drivers folder (as suggested in the blog 
link) - I get he windows message:
"Unable to Create the folder "New Folder". Access is denied.

This seems wrong to me. The /var/lib/samba/drivers folder gives everyone 
write access. As far as I can see - I have done everything possible to 
provide samba access to richard and rhc.

Problem 2 - and probably related to the first:
If I go to \\server and then printers and faxes - I don't see a server 
properties when I right click - but the file menu has the server properties.
I then go to the driver tab. There are no drivers shown - but the "add" 
button is greyed out.

Problem 3:
In a terminal window logged on as root I have tried the command:

net rpc rights grant smulcahy SePrintOperatorPrivilege

It asks for a password - and I give it the root password. This appears 
to work when the "mulcahy" is not a user on my system. However if I put 
a known user on my linux system - I get the error:
Failed to grant privileges for richard (NT_STATUS_ACCESS_DENIED)

Thanks for your help.

Best regards


Ryan Novosielski wrote:
> Hash: SHA1
> Richard Chapman wrote:
>> Hi Willy, Dale, Ryan and others
>> Many thanks for hte feedback. I had read the man samba.conf section on
>> "use client driver" - but I interpreted the "MUST not be enabled when
>> valid printer drivers are loaded on the Samba server" to mean the case
>> where the drivers were "loaded on and RUNNING on the server" as opposed
>> to "loaded on the server simply to allow them to be loaded onto the
>> windows box". These are presumably different cases - and it is clearly
>> desirable to upload the drivers on the server JUST for download to the
>> windows box even when (especially when) the drivers are running on the
>> client side.
> Misinterpretation. With Samba, the only thing you can do is have them
> available for download. The drivers always run on the client side
> (HP-UX, in my example, isn't actually going to do anything server-side
> with the drivers). Use client driver means something like "completely
> ignore the server side drivers and use a local one."
>> I have tried removing the directive - and I immediately get back the
>> "access denied" status in the windows printers and faxes window, just as
>> the man pages suggest I should. Since removing the directive (and
>> restarting samba) I have tried again to upload the drivers - but the
>> result is the same. It goes through the motions - and doesn't give an
>> error - but still uploads to the c:\windows..  on the client rather than
>> the print$ share on the samba server.
> You don't say how you're doing this -- this might be part of the
> problem. You may also have said before, but is this a domain, or just a
> workgroup? That may make a difference.
>> Thanks for your references too Dale - but my "Access Denied" error is
>> seen on the printer and fax status window - rather than when trying to
>> upload drivers. I do not get any errors when uploading the drivers. They
>> just go to the wrong place. No doubt when I get them going to the right
>> place - I may then need to resolve the privileges issue. I will however
>> have a good browse of the howto link you provided.
>> I guess it does appear that the "use client driver" is preventing me
>> from uploading the drivers. Can anyone suggest the best way around this?
>> There are a few linux drivers around for the printer - but they all seem
>> to have problems. Can I install a linux driver - but not use it and
>> still use the windows client side drivers. Will this overcome my problem
>> - and allow me to upload the Windows drives to the linux share?
> No.
>> Alternatively - can I run the system with a "raw" mode linux printer -
>> but avoid the "use client driver". Is there some other way to get rid of
>> "access denied" errors - or can I just ignore them? In this case - with
>> no linux driver installed - can I still upload windows printer drivers?
> Yes. Not knowing really what you did wrong (you may very well have said
> but I did not have the time to follow it), I can't really tell you, but
> I can say that I followed the HOWTO and it does work as expected.
>> One simple question you may be able to answer: Is it the presence of the
>> "use client driver" directive or the absence of the linux driver which
>> prevents me from uploading? My tests today suggest the latter.
> Linux drivers are irrelevant. Printing in Samba doesn't actually do any
> printing (communicating with a physical device), it is basically like a
> write-only file share with generates a spool file and passes it off to
> your real printing system. Samba will then also interface with this
> printing system to check printer status. You have not gotten that far,
> however.
>> Many thanks again.
>> Richard.
>> Willy Offermans wrote:
>>> Hello Richard,
>>> On Wed, Jan 02, 2008 at 11:19:04PM +0900, Richard Chapman wrote:
>>>> Hi. I have been following another thread describing problems
>>>> uploading printer drives - but I think I have a different problem.
>>>> In my case I have a Samsung CLP510 colour laser physically connected
>>>> to a Centos 5.1 X86-64 Linux box with Samba 3.0251514
>>>> (3.0.25b-1.el5_1.4
>>>> <>).
>>>> The Printer is intended to be shared by windows boxes on the network.
>>>> I have installed the printer as a "raw" printer - so that windows
>>>> clients use their own drivers. In order to get rid of the "Access
>>>> Denied" errors in the "Printers and Faxes" status - I have put the
>>>> "use client driver" directive into smb.conf.
>>>> I was hoping that I could still install windows printer drivers on
>>>> the Linux server so that new windows client machines would not have
>>>> to find the driver elsewhere. I can't see any reason why this should
>>>> not be possible. I have created the print$ share and the folders
>>>> described here:
>>>> http://wiki.samba.org/index.php/Samba_as_a_print_server
>>>> It looks like some parts of this wiki are rather incomplete.
>>>> The printer works fine from the clients now (if I provide the client
>>>> driver elsewhere) - but I cannot get the drivers to load on the server.
>>>> If I browse the network - from a windows client - and select the
>>>> properties of the printer within the "Printers and Faxes" folder -
>>>> then select "Advanced", and then select "New Driver" - it starts the
>>>> "Add Printer driver" wizard. I can select the driver I want and
>>>> "Finish" the wizard - but it uploads the driver to the
>>>> /windows/system32/spool/drivers folder on the local client rather
>>>> than the server.
>>>> Can anyone tell me if I am doing something wrong - or if there is
>>>> something wrong with my configuration which prevents me from
>>>> uploading the driver to the server?
>>>> Many thanks.
>>>> Richard.
>>>> -- 
>>>> To unsubscribe from this list go to the following URL and read the
>>>> instructions:  https://lists.samba.org/mailman/listinfo/samba
>>> If I recall correctly, then the "use client driver" directive prohibits
>>> the up-/download of printer drivers from the server. Please search the
>>> net to be 100% sure. I remember there was a hint about the issue in
>>> `man smb.conf`:
>>> <snip>
>>>           use client driver (S)
>>>     <snip>
>>>              If  this  parameter is enabled for a printer, then any
>>> attempt to
>>>              open the printer  with  the  PRINTER_ACCESS_ADMINISTER
>>> right  is
>>>              mapped  to  PRINTER_ACCESS_USE  instead.  Thus allowing
>>> the Open-
>>>              PrinterEx() call to succeed.  This parameter  MUST  not
>>> be  able
>>>              enabled  on  a print share which has valid print driver
>>> installed
>>>              on the Samba server.
>>>     </snip>
>>> </snip>
>>> Although the text: "This parameter  MUST  not be ..." is not clear for
>>> 100% and rather difficult to read, it makes sense that having the
>>> printer driver on the server and using the client driver at the same
>>> time is ambiguous. Concerning the "Access Denied" errors, I do not know
>>> what happens, after you have removed the appropriate directive in your
>>> smb.conf.
>>> I hope this helps.
> - --
>  ---- _  _ _  _ ___  _  _  _
>  |Y#| |  | |\/| |  \ |\ |  | |Ryan Novosielski - Systems Programmer II
>  |$&| |__| |  | |__/ | \| _| |novosirj at umdnj.edu - 973/972.0922 (2-0922)
>  \__/ Univ. of Med. and Dent.|IST/AST - NJMS Medical Science Bldg - C630
> Version: GnuPG v1.4.6 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> iD8DBQFHfQl8mb+gadEcsb4RAjpgAKDTCg0hCibuUhJbF2ErMy9LyQ0YoACeIliF
> JtGshEpLjhijkCbtS4H0zXw=
> =WU9Y

More information about the samba mailing list