[Samba] Another Uploading Printer drivers problem.

Richard Chapman rchapman at aardvark.com.au
Thu Jan 3 13:15:01 GMT 2008

Hi Willy, Dale, Ryan and others

Many thanks for hte feedback. I had read the man samba.conf section on 
"use client driver" - but I interpreted the "MUST not be enabled when 
valid printer drivers are loaded on the Samba server" to mean the case 
where the drivers were "loaded on and RUNNING on the server" as opposed 
to "loaded on the server simply to allow them to be loaded onto the 
windows box". These are presumably different cases - and it is clearly 
desirable to upload the drivers on the server JUST for download to the 
windows box even when (especially when) the drivers are running on the 
client side.

I have tried removing the directive - and I immediately get back the 
"access denied" status in the windows printers and faxes window, just as 
the man pages suggest I should. Since removing the directive (and 
restarting samba) I have tried again to upload the drivers - but the 
result is the same. It goes through the motions - and doesn't give an 
error - but still uploads to the c:\windows..  on the client rather than 
the print$ share on the samba server.

Thanks for your references too Dale - but my "Access Denied" error is 
seen on the printer and fax status window - rather than when trying to 
upload drivers. I do not get any errors when uploading the drivers. They 
just go to the wrong place. No doubt when I get them going to the right 
place - I may then need to resolve the privileges issue. I will however 
have a good browse of the howto link you provided.

I guess it does appear that the "use client driver" is preventing me 
from uploading the drivers. Can anyone suggest the best way around this? 
There are a few linux drivers around for the printer - but they all seem 
to have problems. Can I install a linux driver - but not use it and 
still use the windows client side drivers. Will this overcome my problem 
- and allow me to upload the Windows drives to the linux share?

Alternatively - can I run the system with a "raw" mode linux printer - 
but avoid the "use client driver". Is there some other way to get rid of 
"access denied" errors - or can I just ignore them? In this case - with 
no linux driver installed - can I still upload windows printer drivers?

One simple question you may be able to answer: Is it the presence of the 
"use client driver" directive or the absence of the linux driver which 
prevents me from uploading? My tests today suggest the latter.

Many thanks again.


Willy Offermans wrote:
> Hello Richard,
> On Wed, Jan 02, 2008 at 11:19:04PM +0900, Richard Chapman wrote:
>> Hi. I have been following another thread describing problems uploading 
>> printer drives - but I think I have a different problem.
>> In my case I have a Samsung CLP510 colour laser physically connected to 
>> a Centos 5.1 X86-64 Linux box with Samba 3.0251514 (3.0.25b-1.el5_1.4 
>> <>). 
>> The Printer is intended to be shared by windows boxes on the network. I 
>> have installed the printer as a "raw" printer - so that windows clients use 
>> their own drivers. In order to get rid of the "Access Denied" errors in the 
>> "Printers and Faxes" status - I have put the "use client driver" directive 
>> into smb.conf.
>> I was hoping that I could still install windows printer drivers on the 
>> Linux server so that new windows client machines would not have to find 
>> the driver elsewhere. I can't see any reason why this should not be 
>> possible. I have created the print$ share and the folders described here:
>> http://wiki.samba.org/index.php/Samba_as_a_print_server
>> It looks like some parts of this wiki are rather incomplete.
>> The printer works fine from the clients now (if I provide the client 
>> driver elsewhere) - but I cannot get the drivers to load on the server.
>> If I browse the network - from a windows client - and select the 
>> properties of the printer within the "Printers and Faxes" folder - then 
>> select "Advanced", and then select "New Driver" - it starts the "Add 
>> Printer driver" wizard. I can select the driver I want and "Finish" the 
>> wizard - but it uploads the driver to the 
>> /windows/system32/spool/drivers folder on the local client rather than 
>> the server.
>> Can anyone tell me if I am doing something wrong - or if there is 
>> something wrong with my configuration which prevents me from uploading 
>> the driver to the server?
>> Many thanks.
>> Richard.
>> -- 
>> To unsubscribe from this list go to the following URL and read the
>> instructions:  https://lists.samba.org/mailman/listinfo/samba
> If I recall correctly, then the "use client driver" directive prohibits
> the up-/download of printer drivers from the server. Please search the
> net to be 100% sure. I remember there was a hint about the issue in
> `man smb.conf`:
> <snip>
>           use client driver (S)
> 	<snip>
>              If  this  parameter is enabled for a printer, then any attempt to
>              open the printer  with  the  PRINTER_ACCESS_ADMINISTER right  is
>              mapped  to  PRINTER_ACCESS_USE  instead.  Thus allowing the Open-
>              PrinterEx() call to succeed.  This parameter  MUST  not be  able
>              enabled  on  a print share which has valid print driver installed
>              on the Samba server.
> 	</snip>
> </snip>
> Although the text: "This parameter  MUST  not be ..." is not clear for
> 100% and rather difficult to read, it makes sense that having the
> printer driver on the server and using the client driver at the same
> time is ambiguous. Concerning the "Access Denied" errors, I do not know
> what happens, after you have removed the appropriate directive in your
> smb.conf.
> I hope this helps.

More information about the samba mailing list