[Samba] Samba server joining domain and browsing group shares

Victor Mendez vmendez at netsystemsinfo.com
Fri Feb 29 16:06:44 GMT 2008

Alex I thank you for you patience, but it is not working.

I have implemented the following changes: 

1st change to /etc/nsswitch:
  > The file /etc/nsswitch.conf must look like this for winbind to run
  > properly: passwd:     files winbind
  > shadow:     files
  > group:      files winbind

2nd change to /etc/samba/smb.conf
> The problem resides here: "winbind separator = +"
> Remove that entry and now the seperator will be "\"

Output of getent command:

cuzco:~ # getent group "NETSYS\Documentaries"

cuzco:~ # getent group "NETSYS\Series"

cuzco:~ # getent group "NETSYS\Movies"

So it looks as we have solved the winbind separator problem .

But we still get no directory browse. I include the output of 
the /var/log/samba/* files group when I try to login from a workstation
see smb-logs.tar.gz

In this file there is two errors that brough my attention:
1st error =
 02/29/2008 10:22:01 AM	libads/kerberos_verify.c	ads_keytab_verify_ticket	172	
ads_keytab_verify_ticket: krb5_rd_req failed for all 12 matched keytab 

2nd error =
02/29/2008 10:22:01 AM	lib/util_sid.c	string_to_sid	223	string_to_sid: Sid 
@NETSYSTEMSINFO>COM\Documentaries does not start with 'S-'.

what I try to do is I try to browse/connect to the Documentaries share

It looks like we are stuck...

Thanks again, regards


More information about the samba mailing list