[Samba] Joining an AD domain

Tom Weishaupt tom.weishaupt at distributel.ca
Fri Feb 15 14:19:26 GMT 2008

I was wondering if anyone knows the solution to this little problem?
I have several Linux boxes that connect to a Windows 2003 AD domain.
However I currently cannot connect any new Linux computers to the domain
even though the distributions are all the same and the smb.conf,
krb5.conf are identical on all the boxes..
When I run kinit -Uadministator at domain I get a ticket issued. However
when I issue the net ads join -Uadministator at domain command the first
time it just appears to hang. I CNTRL+C and re-issue the command and it
says machine account already exists- modifying old account and appears
to hang. I can leave this for several days and it never respond with
Machine joined Domain. 
I also cannot get domainUser or domainGroup information.
I have recently removed an existing working system from the domain and
tried to log it back into the domain and now get the same machine
account already exists- modifying old account message and it will not
rejoin the domain.
ANY IDEAS........in need of HELP desperately....

More information about the samba mailing list