[Samba] Can I have share name "shareone" and "share one" at the same time?

Young-Jun Oh yjonly at gmail.com
Wed Feb 27 05:42:33 GMT 2008

Hello Samba community!

I recently found out interesting behavior of share name with Samba and did
not find any useful information on the net. If anyone knows why I'm having
this problem, I would feel like I could fly!

Thanks in Advance.

The problem I have is that I can not get following two shares working at the
same time.

in my smb.conf file,

comment = shareone
printable = no
public = yes
writeable = Yes

[share one]
comment = share one
path=/share one
printable = no
public = yes
writeable = Yes

I can get either one of them to work but not at the same time. I tried
quote(") around share one. I tried "share\ one". I tried share\040one. But
none of them worked.

I tried these names for share in Windows XP and they worked fine at the same

I'm sure this kind of share names on same computer would be very rare but
I'm just curious.


More information about the samba mailing list