[Samba] ldap passwd sync not working [solved]

Fabiano Caixeta Duarte fcd.listas at gmail.com
Fri Feb 15 18:44:34 GMT 2008

Jerome Tournier escreveu:
> I tried on CentOS release 4.6 (Final)
> samba-3.0.25b-1.el4_6.4
> openldap-servers-2.2.13-8.el4_6.2
> smbldap-tools-0.9.5-pre4 (but changing password work with latest
> packages)
>> I'm using FreeBSD 6.3 in both samba and openldap servers, Samba 3.0.26a and 
>> openldap 2.3.38. Not using PAM.

You kind of helped me. Looking at openldap version (2.2) I remembered 
that I had ldap passwd sync working with this version of LDAP. So I 
looked for what has changed between 2.2 and 2.3 versions of Openldap. I 
found password policy, which seems to be mandatory for this whole thing 
to work with earlier versions of Samba.

So, I (re)compiled openldap-server with ppolicy support and inserted 
this two lines in my slapd.conf:

include	/path/to/schema/ppolicy.schema
overlay ppolicy

Thanks for everyone who tried helping.

Fabiano Caixeta Duarte
Especialista em Redes de Computadores
Linux User #195299
Ribeirão Preto - SP

More information about the samba mailing list