[Samba] build of 3.3.0rc2 on opensolaris 2008.11 causes ld usage error

Zach Wilkinson ztwilkinson at yahoo.com
Sun Dec 21 16:39:43 GMT 2008

I just installed OpenSolaris 2008.11 and I wanted to experiment with 3.3.0.

In 'samba-3.3.0rc2/source' I run:
$ ./configure --without-ldap --with-aio-support --build=i686-pc-solaris2.11

I next run 'make' but it soon dies with the following:

Using FLAGS      =  -O -D_SAMBA_BUILD_=3  -I/export/home/zachw/samba-3.3.0rc2/so
urce/iniparser/src -Iinclude -I./include  -I. -I. -I./lib/replace -I./lib/talloc
 -I./lib/tdb/include -I./libaddns -I./librpc -DHAVE_CONFIG_H  -D_LARGEFILE_SOURC
E -D_REENTRANT -D_FILE_OFFSET_BITS=64 -Iinclude -I./include -I. -I. -I./lib/repl
ace -I./lib/talloc -I./lib/tdb/include -I./libaddns -I./librpc -I./popt -DSUNOS5
   -I/include -I/export/home/zachw/samba-3.3.0rc2/source/lib -D_SAMBA_BUILD_=3
      PICFLAG    = -fPIC
      LIBS       = -lsendfile -lresolv -lnsl -lsocket -laio
      LDFLAGS    = -pie  -lthread -L./bin
      DYNEXP     = -Wl,-E
      LDSHFLAGS  = -G  -lthread -L./bin
      SHLIBEXT   = so
      SONAMEFLAG = -Wl,-soname=
Linking shared library bin/libtalloc.so.1
usage: ld [-6:abc:d:e:f:h:il:mo:p:rstu:z:B:CD:F:GI:L:M:N:P:Q:R:S:VW:Y:?] file(s)
        [-64]           enforce a 64-bit link-edit
        [-a]            create an absolute file

...[more usage info]

'which ld' finds /usr/gnu/bin/ld, but gcc uses /usr/ccs/bin/ld.

$ gcc -v
Reading specs from /usr/sfw/lib/gcc/i386-pc-solaris2.11/3.4.3/specs
Configured with: /builds2/sfwnv-gate/usr/src/cmd/gcc/gcc-3.4.3/configure --prefix=/usr/sfw --with-as=/usr/sfw/bin/gas --with-gnu-as --with-ld=/usr/ccs/bin/ld --without-gnu-ld --enable-languages=c,c++,f77,objc --enable-shared
Thread model: posix
gcc version 3.4.3 (csl-sol210-3_4-20050802)

I did notice when running ./configure the following scrolled by:
checking netinet/ip.h usability... no
checking netinet/ip.h presence... yes
configure: WARNING: netinet/ip.h: present but cannot be compiled
configure: WARNING: netinet/ip.h:     check for missing prerequisite headers?
configure: WARNING: netinet/ip.h: see the Autoconf documentation
configure: WARNING: netinet/ip.h:     section "Present But Cannot Be Compiled"
configure: WARNING: netinet/ip.h: proceeding with the preprocessor's result
configure: WARNING: netinet/ip.h: in the future, the compiler will take precedence
configure: WARNING:     ## ---------------------------------------- ##
configure: WARNING:     ## Report this to samba-technical at samba.org ##
configure: WARNING:     ## ---------------------------------------- ##
checking for netinet/ip.h... yes

However I don't believe this is related.

I also tried removing the aio and build=i686 options from the 'configure' arg list but it makes no difference.

I'm planning on trying to build a newer version of gcc that uses GNU ld, but if that's unnecessary that's ok too.



More information about the samba mailing list