[Samba] page cache keeps growing untill system runs out of memory on a MIPS platform

Jeremy Allison jra at samba.org
Thu Dec 4 17:31:05 GMT 2008

On Thu, Dec 04, 2008 at 02:28:15AM -0800, srinivasan jayarajan wrote:
> Hi,
>   I have samba-3.0.28a crosscompiled and running on a MIPS platform. The
> development system has about 150MB of free RAM after system bootup and no swap space. The system also has an USB interface, to which an external USB hard disk is connected.
> When I try to transfer huge files above (100MB) from a client on to the USB hard disk, I find that the page cache eats up almost about 100MB and occasionally the system runs out of memory. I even tried tweaking the /proc/sys/vm settings with the following values, but it did not help.
> /proc/sys/vm/dirty_background_ratio = 2
> /proc/sys/vm/dirty_ratio = 5
> /proc/sys/vm/dirty_expire_centisecs = 1000
> /proc/sys/vm/vfs_cache_pressure = 10000
> I also tried copying the huge file locally from one folder to another through the USB interface using dd oflag=direct flag (unbuffered write). But the page cache again ate away about 100MB RAM. Has anybody here seen the same problem? Is there a possible fix? I believe it's more to do with USB caching or something rather than samba itself

You should raise this on the Linux filesystems
list rather than the Samba list (I'm assuming
it's Linux). We don't do anything to control
the page cache from smbd.


More information about the samba mailing list