[Samba] Failed to join domain using net join ads

Roger Criddle rogercriddle at rocketmail.com
Tue Dec 2 17:04:02 GMT 2008

I have RHEL 5.2 running Samba 3.2.4.   I am trying to join the Samba server to Active Directory (Windows 2003 R2) using net join ads command.    I get the following errors:

As root, I run kinit secadmin which completes successfully and I get a Kerberos ticket.   Secadmin has full domain admin privileges in Active Directory.   Then I run:
#> net join ads -S phxwn01 -U secadmin%password
Failed to join domain: Invalid configuration and configuration modification was not requested.

Or if I run:
#> net join ads
Enter root password:
Failed to join domain: Failed to find DC for domain PHX.ENG  #[Global]

Can anyone provide insight, my config files are listed below:
    workgroup = phx
    interfaces = eth2
    bind interfaces only = true
    server string = 
    password server = phxwn01
    realm = phx.eng
    security = ads
    encrypt passwords = yes

        default_realm = PHX.ENG
        PHX.ENG = {
        kdc = phxwn01.phx.eng:88
        phx.eng = PHX.ENG
        .phx.eng = PHX.ENG

I can ping phxwn01, and I get successful response from nslookup for _kerberos._tcp.phx.eng using type SRV.  I have tried creating the computer account ahead of time in AD.

Thanks for any help,
Roger Criddle
rogercriddle at rocketmail.com


More information about the samba mailing list