[Samba] Solaris nss_ldap vs PADL nss_ldap

Douglas E. Engert deengert at anl.gov
Wed Aug 27 17:59:11 GMT 2008

Duncan Brannen wrote:
> Hi All,
>          Any thoughts on why, while everything seems ok at the OS level 
> (getent , id -a ) Samba
> doesn't pickup any supplementary groups when Solaris is configured with 
> 'group: files ldap' in
> nsswitch.conf and using it's own native nss_ldap.so.1 but does when 
> using PADL's nss_ldap?
> Everything else is equal.

Have you tried using Solaris version withthis in the nsswitch.conf:

  group: compat
  group_compat ldap

and adding the + in the /etc/group file.

This appears to work as expected, getting groups info from both
local and ldap.

Or (I have not tried this):

  group: files [SUCCESS=continue] ldap

> Do they use/accept different calls or could it be an openldap vs native 
> ldap incompatibility,
> Samba being compiled against the openldap libraries.
> Samba seems not to compile against the native libraries due to a lack of 
> ldap_start_tls_s
> Solaris 10 and Samba 3.2.2
> Cheers,
>          Duncan


  Douglas E. Engert  <DEEngert at anl.gov>
  Argonne National Laboratory
  9700 South Cass Avenue
  Argonne, Illinois  60439
  (630) 252-5444

More information about the samba mailing list