[Samba] [ANNOUNCE] Samba 3.2.2 Available for Download

Daniel Eischen eischen at vigrid.com
Fri Aug 22 15:43:55 GMT 2008

On Fri, 22 Aug 2008, Brian H. Nelson wrote:

> James Kosin wrote:
>> Tim,
>> You still may have to move the libraries to their normal spot or make an 
>> entry in /etc/ld.so.conf to point to the directory where the libraries are 
>> kept for samba.
>> James
> On Solaris, one uses the crle command to achieve the same result.
> Aside from that, I believe that the general practice for packages that 
> include their own libraries is to hard-code the libpath into any applicable 
> binaries using '-rpath $prefix/lib' in the linking step (or '-R $prefix/lib' 
> with Solaris ld).
> If you install samba into its own area (say /usr/local/samba) and the 
> libraries are installed in a non-system location (perhaps 
> /usr/local/samba/lib), messing with the runtime linker config to make samba 
> work should NOT be required.

Exactly!  I had the same problem, I believe with 3.0.31.  I
think I solved it by editing the Makefile (after configuring
samba) to add '-R $prefix/lib' as described above.

On Solaris, the configure step _should_ generate a Makefile
with the -R (or -rpath) option above, but it does not.


More information about the samba mailing list