[Samba] Re: AD on 2003R2 NT_STATUS_NO_SUCH_USER

Matt Anderson sokkerstud_11 at hotmail.com
Mon Aug 11 20:43:08 GMT 2008

Matt Anderson <sokkerstud_11 <at> hotmail.com> writes:

I think I may have solved why users were not being found.  When I tried doing
wbinfo -i test01, I got an error stating that information for user could not be
found.  After digging a little bit through the log files, I discovered that the
SID for the Windows Primary Group was being returned, instead of gidNumber for
the user's primary group.  So, I updated the Windows Primary Group in Active
Directory to match the one specified by gidNumber -- and at that point, I was
able to run wbinfo -i test01 and get the following result:

The username, uid, and gecos are correct, however the home directory and shell
are incorrect.  If you look back at the previous post, the attributes in Active
Directory are as follows:

uid: test01
msSFU30Name: test01
msSFU30NisDomain: test
uidNumber: 50002
gidNumber: 1
unixHomeDirectory: /home/test01
loginShell: /usr/bin/ksh

So, my question is, what do I have to do to get Samba to retrieve the correct
attributes?  Or, is it even necessary? (Again, I'm using Windows Server 2003 R2)

Which leads me to my next question -- after making the change to the primary
group, I was able to authenticate successfully against the "testing" share as
user TEST+test01 from my Windows XP box... however, with an examination of the
file system, I determined that any files I created in this samba session end up
having root permissions assigned to them (instead of test01).  For example:
-rwxr--r--    1 root     staff             0 Aug 11 13:28 deleteme.txt
-rwxr--r--    1 root     staff             0 Aug 11 13:28 test1234.txt

The group "staff" is correct, since that is gidNumber 1, however, the owner
should be test01 instead of root.  What am I doing wrong?

Thanks again for your help!

More information about the samba mailing list