[Samba] unable to build 3.2 on HP-UX

Dag Ager dag.ager at enders-ing.de
Mon Aug 4 13:14:55 GMT 2008

Hi all,

I'm trying to build Samba 3.2 on HP-UX 11.11. I already tried different
(without ldap, active directory etc, building in a different directory)
but without
The Problem is independent from configure options - called within the
source tree without any options leads exactly  to the same result.

Here are some informations about my setup:

gcc (GCC) 4.2.3
HP-UX  B.11.11
PA-RISC 2.0 / 64Bit

The following snippets are from my last attempt where i tried to build
in a seperate directory. When I build directly in the source directory
exactly the same happens.

../source/configure --prefix=/opt/samba --with-ldap=no

warnings during configure:

checking arpa/inet.h presence... yes
checking for arpa/inet.h... yes
checking netinet/ip.h usability... no
checking netinet/ip.h presence... yes
configure: WARNING: netinet/ip.h: present but cannot be compiled
configure: WARNING: netinet/ip.h:     check for missing prerequisite
configure: WARNING: netinet/ip.h: see the Autoconf documentation
configure: WARNING: netinet/ip.h:     section "Present But Cannot Be
configure: WARNING: netinet/ip.h: proceeding with the preprocessor's result
configure: WARNING: netinet/ip.h: in the future, the compiler will take
configure: WARNING:     ## ---------------------------------------- ##
configure: WARNING:     ## Report this to samba-technical at samba.org ##
configure: WARNING:     ## ---------------------------------------- ##

--> strage one, perhaps the cause for the problem

checking SONAMEFLAG... -Wl,+h
checking PICFLAG... -fPIC
checking whether building shared libraries actually works... (Bundled)
cc: warning 422: Unknown option "b" ignored.
/usr/ccs/bin/ld: CODE_ONE_SYM fixup to non-code subspace in file
/usr/ccs/lib/crt0.o - shared library must be position independent. Use
+z or +Z to recompile.
checking used PICFLAG... -fPIE
checking for long long... yes
checking for intptr_t... (cached) yes
checking for LL suffix on long long integers... yes
checking for Active Directory and krb5 support... auto
configure: WARNING: Disabling Active Directory support (requires LDAP
checking for nscd_flush_cache in -lnscd... no
checking whether to use shared libraries internally... false
configure: WARNING: --enable-shared-libs: no support for shared libraries
checking whether to build the libtalloc shared library... no shared
library support -- will supply static library

--> no more warnings and no errors at all during configure.

compiler error:


Compiling librpc/gen_ndr/ndr_libnet_join.c
mkdir nsswitch/libwbclient
Compiling nsswitch/libwbclient/wbclient.c
Compiling nsswitch/libwbclient/wbc_util.c
Compiling nsswitch/libwbclient/wbc_pwd.c
Compiling nsswitch/libwbclient/wbc_idmap.c
Compiling nsswitch/libwbclient/wbc_sid.c
Compiling nsswitch/libwbclient/wbc_pam.c
Compiling nsswitch/wb_common.c
Linking non-shared library bin/libwbclient.a
Compiling smbd/server.c
../source/smbd/server.c: In function 'main':
../source/smbd/server.c:1100: warning: passing argument 2 of
'set_auth_parameters' from incompatible pointer type
Linking bin/smbd
sh[7]: bin/nmbd::  not found.
*** Error exit code 127


--> as a test: created directory nmbd and restarted make:


11:02 da:en6[86]

Using FLAGS      =  -O -D_SAMBA_BUILD_=3
-I/opt/build/samba-3.2.0/build/../source/iniparser/src -Iinclude
-I/opt/build/samba-3.2.0/build/../source/include -I.
-I/opt/build/samba-3.2.0/build/../source/librpc -DHAVE_CONFIG_H
-Iinclude -I../source/include -I. -I../source -I../source/lib/replace
-I../source/lib/talloc -I../source/lib/tdb/include -I../source/libaddns
-I../source/librpc -I../source/popt   -I/include
-I/opt/build/samba-3.2.0/build/../source/lib -D_SAMBA_BUILD_=3
      PICFLAG    = -fPIE
      LIBS       = -lsec -lnsl -liconv
      LDFLAGS    = -pie  -L./bin
      DYNEXP     = -Wl,-E,+b/usr/local/lib:/usr/lib
      LDSHFLAGS  = shared-libraries-disabled  -L./bin
      SHLIBEXT   = shared_libraries_disabled
      SONAMEFLAG = shared-libraries-disabled
Linking non-shared library bin/libtalloc.a
WARNING: you need to run ./config.status
Linking non-shared library bin/libsmbclient.a
Linking non-shared library bin/libsmbsharemodes.a
Linking bin/smbd
sh[7]: bin/nmbd::  not found.
*** Error exit code 127

--> not really better...

Anyone an Idea? Are there any known Problem with the version of gcc I use?


More information about the samba mailing list