[Samba] Mis-behavior of ldap.conf regarding nss?

Adam Tauno Williams adamtaunowilliams at gmail.com
Wed Apr 23 19:25:37 GMT 2008

> I run a samba 3.0.26a-1ubuntu2.3 on an Ubuntu 7.10 server with OpenLDAP 
> both for samba and for posix accounts. Everything runs fine, except for 
> one problem. I have a ou=People-inactive branch on my ldap server on 
> wich I store (guess what?) inactive people. I don't want my system to 
> recognize those entries as valid users, so I set my /etc/ldap.conf as 
> follows:
> nss_base_passwd         ou=People,dc=a1,dc=ind?one
> The problem arose when I tried to add a new machine to the domain. The 
> smbldap-useradd script is able to add the machine entry on ldap, but the 
> whole process fails with "User not found" (translated from the 
> Portuguese message) on the adding workstation. After googling for about 
> 3 hours without success, I found that if I just comment out the 
> nss_base_* entries, everything works as expected and am able to join a 
> machine to the domain.

Does your script create the machine account object in ou=People?  You've
verified the object is created at all and you can successfully "id

> Is that a samba, nss or smbldap-tools bug? Or is this not a bug, but a 
> feature? ;) Or have I lost something?

My guess would be it is bug in your configuration of smbldap-tools.

Adam Tauno Williams, Network & Systems Administrator
Consultant - http://www.whitemiceconsulting.com
Developer - http://www.opengroupware.org

More information about the samba mailing list