RE [Samba] smbldap-useradd -w won't create machine account

Quinn Fissler qfissler at
Wed Apr 2 16:22:04 GMT 2008

samba uses nss_ldap for the check during the add - ie it uses smbldap to add
and then uses nssldap to check the account was created.

The problem arises if the nssldap isn't configured properly.

if you do
   getent passwd
on the samba host, does it work? do you see ldap users or only local

/etc/ldap.conf or /etc/openldap/ldap.conf is the culprit

On 02/04/2008, John Drescher <drescherjm at> wrote:
> On Wed, Apr 2, 2008 at 12:03 PM, Hector Blanco <white.lists at>
> wrote:
> > No? Then how do you say we must do? Because I also tried to do that
> >  from Windows, and it doesn't work... I mean... right click on my pc
> >  and "add machine to domain"... and still doesn't work :S
> >
> I had this in the past. At one point I think I fixed it but I found
> the easiest way around this (that always works) is to use LAM (or some
> other tool to create the required stuff in ldap directly).
> John
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:

More information about the samba mailing list