[Samba] Can't see shares, and also smbmount works but mount -t cifs doesn't

El Shaaarkee lsharkey at inbox.com
Tue Sep 4 13:48:00 GMT 2007

(this is most likely a newbie question).

A couple of problems.   I have a linux guest (puppy) running on vmplayer on a friend's machine, which runs WinXP home. I have folder sharing enabled on the host for a few different folders.   I am trying to mount the winxp host shared folders onto the linux guest.

First problem is that I can't seem to see the shares.  smbtree only lists the host name and the workgroup, as so:


Likewise, smbclient -L JOHNCOMP               or:
                    smbclient -L   

returns this error:

Domain=[COMP] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

	Sharename	Type	Comment
	---------	----	-------
Error returning browse list: NT_STATUS_OK
Domain=[COMP] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

	Server		Comment
	------		-------

	Workgroup	Master
	---------	                     ------

However, the shares *are* there, as I can mount them with e.g.

smbmount //JOHNCOMP/music /mnt/share ,

and have no problems accessing the files from the shared folder "music" on "JOHNCOMP".  I don't seem to need the -o password or username options,  unlike other people out there on google, I don't know why... (Simple file sharing on XP home doesn't have password controls enabled, right?).

Second problem:

Though I can mount the share with smbmount, even though I can't see it with smbtree / smbclient -L, I can't seem to mount it with "mount -t cifs" or "mount -t smbfs".

I get this error:

mount -t cifs //JOHNCOMP/music /share        
mount -t smbfs //JOHNCOMP/music /share

mount: Mounting //KATECOMP/Music on /share failed: Invalid argument

Can anyone help?

PS.  One other thing is that I first tried this set up on my XP partition on my own computer before trying it on my friends, and had no problem seeing my shares with smbtree/smbclient -L...   - seeing as I'm using the same virtual machine on his as on mine, does this mean there is some problem with the networking setup on the XP host itself?

PPS. I've noticed that on my machine I've been able to do all of the above successfully without ever writing my own smb.conf.  Why is this?  How come using smbmount etc. worked ok on *my* computer without needing to do so?

More information about the samba mailing list