ham, [Samba] getent passwd not listing domain users, nsswitch.conf is configured

herman herman at aeronetworks.ca
Thu Oct 18 00:52:19 GMT 2007

Peter Baumgartner wrote:
>>  Peter,
>>  Comment the "idmap backend" and "winbind nss info" parameters to let
>> samba/winbind use the defaults.  If it now works, this means that samba was
>> not retrieving the info from the AD server.
>>  I ran into this problem, gave up, and used the defaults.  You may be more
>> persistent than me and prefer to dig deeper.
>>  Also, you will need to set values for "idmap uid" and "idmap gid".  Try
>> using the values that you currently have commented out.
> Still no luck. Any other thoughts? I've tried running winbind in
> interactive mode and didn't get any response from the getent command.
> Where can I find log info?
Try changing the Administrator password on the Windows AD Server.  This 
will cause Kerberos to fix some things - see the Official Howto for 
details on this trick.



More information about the samba mailing list