[Samba] Problem with samba 3.0.14a-3sarge9 on Debian Sarge

Alessandro FAGLIA a.faglia at farmol.it
Thu Nov 29 07:43:41 GMT 2007

Hi list.
My box is a Debian Sarge with samba 3.0.14a-3sarge4. I created many 
shares for a Windows network, and everything has been working with no 
flaw. The filesystem is Reiser.

After I upgraded to 3.0.14a-3sarge9, I observed a strange behaviour with 
no apparent explanation.

One of shared folders is fed with PDF obtained by scanning documents. 
Yesterday one user clained that somebody deleted a part of these files. 
When I tried to restore the folder from a backup, I had that:
- files seems to be copied correctly on the samba share (at least I can 
see them with an ls command on the server console);
- from a windows machine, I can see only a subset of them.

I tried to copy this list with scp, smb but the outcome is always the same.
After a bit of panic, I downgraded back to 3.0.14a-3sarge4 and the 
problem disappeared.

Did anybody experience strangeness like that?

-- Alessandro

More information about the samba mailing list