[Samba] Can't write to a Samba shared directory from windows XP

Talal jaafar talal.jaafar at gmail.com
Fri May 25 21:29:45 GMT 2007


  I have setup a linux shared directory using Samba. From windows XP, I can
see the shared directory, browse it, read files from it; however, I can't
write to it. I have changed the ownership of the shared directory in linux
to "nobody", changed the group to "nobody", and chmod it 777.

I have looked at threads for similar problems, but I can't get my problem
solved. The error that I am getting is: "Access denied. Make sure the disk
is not full, or write-protected".  This is my smb.conf contents:

# Samba config file
# from (
# Date: 2007/05/23 23:07:05

    netbios name = RAAD3
    server string = Samba Server
    log file = /var/log/samba/%m.log
    max log size = 50
    dns proxy = No
    security = user
    wins support = Yes
    ldap ssl = no
    cups options = raw

    comment = Home Directories
    read only = No
    browseable = No

    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    comment = webserver
    path = /var/www/html
    valid users = chris
    read only = No

I've spent alot of time on this, and I have tried all sort of things with no
luck. Please advise if you have any idea on why I can't copy/write from
windows to the liunx shared directory.

"chris" is the user on the windows machine as well as on linux. For some
reason, I never get prompted for the samba username and passwd to
authenticate the access.



More information about the samba mailing list