[Samba] Samba 3.0.25 Password Expiration, Disk Mapping and Winbindd Warning

imacat imacat at mail.imacat.idv.tw
Thu May 17 14:45:12 GMT 2007

Dear all,

    Hi.  This is imacat from Taiwan.  We have just upgraded from Samba
3.0.24 to Samba 3.0.25, as the samba-announce suggeseted ("... is the
version that servers should be run for ...").  We are running Samba as
our PDC and only server in our domain.  My environment is: x86_64,
Debian 4.0 r0 Etch, kernel 2.6.18, gcc 4.1.2, glibc 2.3.6.  Before
upgrade I have read the WHATSNEW.txt for changes very carefully.  However,
we still have encounter the following unexpected issues that I can't
find any answer anywhere.

     1. Now everytime a user logs in, she/he is prompt that her/his
password is expired and should update it.  No matter she/he updates
her/his password or not, next time she/he logs in she/he is prompt again. 
I have checked the password expiration setting.  Everyone is set to
"never expire".  I have checked the user information with "pdbedit -Lv",

Password last set:    Sun, 08 Apr 2007 04:53:35 CST
Password can change:  Sun, 08 Apr 2007 04:53:35 CST
Password must change: 9223372036854775807 seconds since the Epoch

    Which doesn't seems to have any problem.

     2. Many (if not all) of the previous-mapped disk shares are no
longer working.  Users cannot access their mapped disks.  However, this
seems to be solved if I disconnect and re-map again.

        I have no idea why is it so.  I was heavily reproved for by my
users that they cannot work anymore.  I spent the whole day finding out
how to solve it.  If users may have to re-map their network disks when
upgrading from 3.0.24 to 3.0.25, shouldn't this be noted in WHATSNEW.txt?

     3. When I debugged the above issues, I saw numerous warnings in the
log file:

[2007/05/17 21:00:31, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/17 21:00:31, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/17 21:00:31, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code

        But we are not running winbindd.  I learned from somewhere in
the Samba HOWTO that PDC should not run winbindd.  If I run winbindd,
"force user" fails.  Should I ignore these warnings?  Or is there any
way I can turn off these warnings?  Or does these warnings meansomething
else that I wrongly configured?

    In fact, the most urgent issue is 1.  My boss will kill me for this. 
Will there be any quick patch to fix it?

    Sorry to be a little hush.  The [global] section of my smb.conf is:

	workgroup = WOMB
	server string = Master Server / Linux
	# Be the primary domain controller
	os level = 34
	local master = yes
	preferred master = yes
	domain master = yes
	domain logons = yes
	logon home =
	logon path =
	logon script = logon.bat
	# Run an WINS server
	wins support = yes
	name resolve order = wins lmhosts hosts bcast
	# Log file control
	log level = 2
	log file = /var/log/samba/log
	max log size = 10240
	# Winbind settings
	idmap uid = 10000-19999
	idmap gid = 10000-19999
	# Security settings
	username map = /etc/samba/users.map
	encrypt passwords = yes
	enable privileges = yes
	# Printing
	load printers = yes
	printing = cups
	printcap name = cups
	# Miscellaneous
	unix charset = big5
	dos charset = big5
	locking = yes
	strict locking = yes
	time server = yes
	read only = no

Best regards,
imacat ^_*' <imacat at mail.imacat.idv.tw>
PGP Key: http://www.imacat.idv.tw/me/pgpkey.txt

<<Woman's Voice>> News: http://www.wov.idv.tw/
Tavern IMACAT's: http://www.imacat.idv.tw/
TLUG List Manager: http://lists.linux.org.tw/cgi-bin/mailman/listinfo/tlug
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba/attachments/20070517/e6417880/attachment.bin

More information about the samba mailing list