[Samba] samba doesn't map to guest account

Michael Nice gummnmi-live at yahoo.de
Thu May 10 02:36:20 GMT 2007

Hi group,

now after 6 hours non-stop trying to solve this issue I decided to
contact the list!
I actually just want to mount an samba share as guest via "mount -t cifs
...", but I alway get a "mount error 13 = Permission denied".

I tried the following (and many else)

  mount -t cifs // /mnt/ebooks -o guest
  mount -t cifs // /mnt/ebooks -o

(both also with the sec options none,ntlm,ntlmi,ntlmv2,ntlmv2i or smbfs
instead of cifs) and always got "mount error 13 = Permission denied". I
just wanted samba to map me to the guest-account but it wouldn't!!!!

I then tried

  mount -t cifs // /mnt/ebooks -o

(where realuser is a privileged user that really exists) and it worked!!

I also tried

  mount -t cifs // /mnt/ebooks -o guest

(where 'upload' has a force user/group option set. Look below in
smb.conf) and it worked!! Yes, it mapped me to the right account!!

But no matter what I did SAMBA-WON'T-MAP-MY-ACCOUNT-TO-GUEST on other
shares than upload!!!

Btw: I can connect with a windows-client and I can connect with
smbclient and it works like a charm - which makes me much more confused ?:-(

Is this a general issue or am i just too stupid to find the solution??


M i c h a e l

gentoo 2.6.20-gentoo-r7
mount.cifs version: 1.10-3.0.24

gentoo 2.6.19-gentoo-r5
samba v3.0.24

--------------- smb.conf ---------------
workgroup = GALLIA
netbios name = Asterix
server string = Asterix
log file = /var/log/samba/log.%m
log level = 3 passdb:10 auth:1 winbind:2
max log size = 50
hosts allow = 172.16.0. 192.168.
guest account = smbguest
map to guest = bad user
security = user
encrypt passwords = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no
hide dot files = no
domain master = no
domain logons = no
preferred master = no
oplocks = no
display charset = UTF-8
unix charset = UTF-8

comment = eBook Directory
path = /samba/ebooks
public = yes
writeable = no
write list = @smbroot
force group = +smbroot
directory mask = 0775
create mask = 0664

comment = Upload Directory
path = /samba/upload
public = yes
writeable = yes
force user = smbguest
force group = smbguest
directory mask = 0775
create mask = 0664


More information about the samba mailing list