[Samba] problems with winbind, ads on 3.0.25rc3

Guillermo Gutierrez ggutierrez at marketscan.com
Tue May 1 18:11:21 GMT 2007

I am having a problem getting active directory domain users to
authenticate on my gentoo and debian systems with v3.0.25rc3 when it
worked perfectly with v3.0.24. I am wondering if it is something in my
configure options.


Wbinfo returns users, groups and the rpc call test succeeds. The getent
command only shows the local users.

I have double checked my nsswitch.conf as well to make sure that it
references winbind.


Here is my configure command:































I have kept the same config that worked with the older version:



        workgroup = MARKETSCAN

        realm = MARKETSCAN.COM

        server string = %h Samba Server, %v

        interfaces = eth0, lo

        bind interfaces only = Yes

        security = ADS

        log level = 3

        log file = /var/log/samba/log.%m

        max log size = 50

        client signing = Yes

        load printers = No

        os level = 2

        preferred master = No

        local master = No

        domain master = No

        dns proxy = No

        ldap ssl = no

        socket address =

        idmap uid = 10000-20000

        idmap gid = 10000-20000

        template homedir = /home/MARKETSCAN/%U

        template shell = /bin/bash

        winbind enum users = Yes

        winbind enum groups = Yes

        winbind use default domain = Yes



        comment = Home Directory for %U

        path = /home/MARKETSCAN/%U

        valid users = %D\%U

        create mask = 0700

        directory mask = 0700

        browseable = No

        vfs objects = readahead



        comment = Public Share on %h

        path = /home/samba/public

        valid users = +users, "@MARKETSCAN\domain users"

        read only = No

        create mask = 0755

        vfs objects = readahead


I would really appreciate any and all help with this.


Also my kernel version is 2.16.20 on gentoo and 2.6.18 on debian. Both
have the same problem.

More information about the samba mailing list