[Samba] uploading printer drivers

Dave dmehler26 at woh.rr.com
Thu Mar 29 21:08:23 GMT 2007

    I'm trying to set up a CentOS 4.4 print server. I've attached a Usb Hp 
Deskjet 5150 printer to the box, and printed a test page. This worked fine, 
using cups. I then went to the samba howto, classical printer section, and 
followed the section for uploading pointprint drivers to the box. My first 
problem came when i told the error dialog no, then didn't see a new driver 
button in the resulting dialog either on the general tab or sharing tab. I 
next tried again, this time i said yes to the driver installation, went 
through, had the apw find the drivers, on my CD, and it uploaded them no 
errors or so i thought. The process completed without errors, the rom and 
the hard disk moved, yet checking the samba box in the print$ share nothing 
has been added and i have global permissions set for this operation. I am 
doing this as a member of the printeradmins group and in smb.conf i did set:

use client driver = no
default devmode = yes

for i have had an issue with a previous deskjet uploading drivers, that one 
actually gave me an error, and adding default devmode fixed it. My samba 
version is 3.0.10 if that helps.
    Any suggestions welcome.

More information about the samba mailing list