[Samba] One of the SOLUTIONS for winbind authenication failures with STATUS_BUFFER_OVERFLOW

Alex Barylo abarylo at gmail.com
Mon Mar 26 14:45:21 GMT 2007

I had this problem and I could not find the solution on Usenet that's
why I'm posting - maybe somebody more fortunate won't have to spend
hours and hours to fix this.

Problem: successfully joined Samba to Windows AD. wbinfo -g and wbinfo
-u worked fine, wbinfo -t did not:
  # wbinfo -t
  checking the trust secret via RPC calls failed
  error code was STATUS_BUFFER_OVERFLOW (0x80000005)
  Could not check secret

Also, if I tried connecting to the share from Windows it would
silently fail. When tried mounting from Linux, would get this:
  # mount -tcifs //sambahost/share /mnt/samba_share
  mount error 5 = Input/output error
  Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

As it turned out my problem was that the Linux host name was too long
- over 14 chars. Once I shrunk it to 14 and rejoined the domain -
everything started working.


More information about the samba mailing list