[Samba] Fatal Samba bug? Why can't anyone answer this question?

Ron House house at usq.edu.au
Mon Mar 12 06:00:23 GMT 2007

Hi all,

I ran into a problem with samba and immediately googles for answers. I 
found 30-odd references to places where this question has been asked 
before, but no answers. I asked it myself here and got no answer.

Perhaps this is this a fatal bug in samba if no one knows how to fix it. 
Below is my original question:


Subject: Can't solve: ERRSRV - ERRbadpw (Bad password - name/password pair

Hi, I have four computers on a home network:

A) A 2004-era debian machine
B) A 2005-era debian machine
C) A 2007 xandros machine
D) A 2007 kubuntu machine

The problem: Machines B and C allow users to mount samba shares, but 
machines A and D don't. I get:

smbmount //spk/homes ~/mnt
3573: tree connect failed: ERRSRV - ERRbadpw (Bad password - 
name/password pair in a Tree Connect or Session Setup are invalid.)
SMB connection failed

I have gone crazy trying to fix this problem, but it doesn't seem to 
depend at all on what is in the /etc/samba/smb.conf file. I even copied 
the working conf file from C to D (suitably editing machine names etc.), 
but got exactly the same error. I have run through so many totally 
different smb.conf files, I am sure that it isn't that that is causing 
the trouble. For example, here is one that works on C but not on D:

workgroup = gemmie
server string=%h (Kubuntu Desktop)
dns proxy=no
name resolve order=lmhosts host wins bcast
log file=/var/log/samba/log.%m
max log size=1000
panic action=/usr/share/samba/panic-action %d
encrypt passwords = true
passdb backend=tdbsam
ldap delete dn=yes
obey pam restrictions=yes
invalid users=root
map to guest=Bad User
passwd program=/usr/bin/passwd %u
passwd chat=*Enter\snew\sUNIX\spassword:* %n\n 
*Retype\snew\sUNIX\spassword:* %n\n .
client use spnego=no
load printers=no
printcap name=cups
dos filetimes=yes
socket options=TCP_NODELAY
display charset=iso8859-1
unix charset=iso8859-1
preserve case=yes
case sensitive=no
short preserve case=yes
os level=20

         create mask = 0775
     comment = Home Directories
     directory mask = 0775
     writeable = yes
         path = /home/%u
         case sensitive = yes

A few more facts: the user attempting to mount the share has the same 
uid and password on all machines, so unless there is some other password 
somewhere in the samba system, it _is_ getting the right password. 
Furthermore, all machines can ssh and scp to/from all others.

To make matters worse, I can't find any error logs. A recursive grep on 
/var/log for samba only finds the startup messages from when the machine 
is turned on.

I am desperate, desperate, I tell ya! All ideas VERY gratefully accepted!!!

BTW, when changing smb.conf, what is the recommended way to restart the 
samba server with the new settings? The man pages aren't too clear on that.

Ron House       house at usq.edu.au

This email (including any attached files) is confidential and is for the
intended recipient(s) only.  If you received this email by mistake,
please, as a courtesy, tell the sender, then delete this email.

The views and opinions are the originator's and do not necessarily
reflect those of the University of Southern Queensland.  Although all
reasonable precautions were taken to ensure that this email contained no
viruses at the time it was sent we accept no liability for any losses
arising from its receipt.

The University of Southern Queensland is a registered provider of
education with the Australian Government (CRICOS Institution Code No's.
QLD 00244B / NSW 02225M)

More information about the samba mailing list