[Samba] Windows won't recognize hostname of server

Don.Walters at FalconJet.com Don.Walters at FalconJet.com
Fri Mar 9 14:44:49 GMT 2007

I'm trying to add a samba server to our company network.  The samba version is 3.0.10 running on Fedora Core 1.  I posted this question a week ago but only one person responded saying he would help me but then he disappeared and nobody else responded.

The problem I'm having is the Windows computers (XP and 2000) that are trying to connect to the server won't recognize the hostname of the server - only the IP address.  For example, putting in \\192.zzz.yyy.xxx will display the shares just fine, but putting in the hostname \\mis001 will not.  The error says that "The account is not authorized to login from this station".

I started Googling for the answer and I discovered the common solution involves the use of encrypted passwords.  I have completely exhausted this solution to no avail.  I have tried adding the declaration "encrypt passwords = yes" into my config file and I have tried adjusting the windows registry settings to enable or disable the use of encrypted passwords.  This doesn't seem to be the answer.

When I go to the Windows command prompt and type... "net use \\mis001 /user:myuserid" the prompt responds with "the command completed successfully".  Once I do that and go to My Computer and put in the hostname \\mis001 it displays my shares!  It seems this command is all I need to make it work, but I don't want to make a login script for every Windows computer that needs to connect to this server.

When I don't include a userid in my DOS command, I get the error message...

System Error 1240 has occurred
The account is not authorized to login from this station.

Strangely I can include just about any valid userid on the Windows domain and it will happily accept it.

Here's my config file.  Some of the commands I'm using here may look a little wonky but this is the current state of my config.  I've been changing and changing different commands for a couple of weeks now trying to make it work, so there were a few times where I got desperate and tried using commands that may not belong together.  Also note that I'm censoring some of the values. I hate doing that since it limits everyone's ability to help me, but since this is a company server, I don't want to get in trouble for posting this stuff.  I also have not shown the individual shares I'm exporting, but it shouldn't make any difference because the root of my problem is in the global settings, I believe.

        workgroup = OURCO
        netbios name = mis001
        server string = MIS Support Server
        security = SHARE
        password server = <censored> # Don't even know if I need this, considering its security = share
        log file = /var/log/samba/log.%m
        read raw = No
        name resolve order = wins host bcast
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192 SO_KEEPALIVE
        load printers = No
        lm announce = Yes
        wins server = <censored>
        kernel oplocks = No
        ldap ssl = no # I am using ldap for dns resolution so I figured this may help
        preload = Yes
        force user = <censored>
        force group = <censored>
        guest ok = Yes
        null passwords = yes

I should also mention that I've been over and over this in regards to my DNS.  I have added the machine to LDAP.  I can ping the machine's hostname from other hosts.  I can also put http://mis001 in the browser and I can view the web server that's running there too.  I feel pretty sure the DNS is setup correctly but I'm not above the possibility that something could be wrong.

Strangely, I have one user (on a Windows client) who has no trouble connecting to the share using the hostname (i.e. \\mis001).  This is completely bizarre because he and I are both on the same subnet as the samba server and I am unable to connect unless I run the DOS command mentioned earlier.

I would appreciate any help you all can provide.

Thank you all in advance.

More information about the samba mailing list