[Samba] /etc/fstab and windows share problem

Miguel Da Silva - Centro de Matemática mdasilva at mordred.cmat.edu.uy
Wed Mar 7 10:17:54 GMT 2007

Dariusz Trzaska escreveu:
> Hi,
> I`ve got a problem with samba and /etc/fstab.
> I have a second computer running Windows XP SP2 with Western Digital 
> MyBook USB2 external hard disk attached. The Disk is shared over windows 
> network with a label "My Book (J)".
> I can manually mount this samba resource by typing "sudo mount -t smbfs 
> -o fmask=777,dmask=777,guest '//win/My Book (J)' /media/MyBook", but I 
> can't figure out how to mount it by using fstab...
> The problem is with the disk label, as it contains three strings: "My", 
> "Book" and "(J)".
> I tried:
> //win/My Book (J) /media/MyBook smbfs guest,dmask=777,fmask=777 0 0
> and
> '//win/My Book (J)' /media/MyBook smbfs guest,dmask=777,fmask=777 0 0
> I also tried replacing ' with " but nothing has changed.
> PS. Windows doesn't allow me to share the disk with one-word label... 
> the ... (J) is always there.
> Plz someone help me,
> SaneOne

Are you using some mount daemon like autofs? If not, you could (like a 
last option) make a Bash script to mount this share when system boots.

I don't remember very well if /etc/fstab accept this "kind" of file 
system name to mount.

Good luck.
Miguel Da Silva
Administrador de Red
Centro de Matemática - http://www.cmat.edu.uy
Facultad de Ciencias - http://www.fcien.edu.uy
Universidad de la República - http://www.rau.edu.uy

More information about the samba mailing list