[Samba] Invalid Argument ls dir mounted share

Max Kipness max at assuredata.com
Thu Jun 14 19:29:43 GMT 2007

Actually, if I split the directory in two, each gets read just fine, so yes,
all are valid file names.

As Anderson pointed out, this bug has been posted. There are actually
several bug posting based on this same error. Seems this broke with Fedora 5
kernel updates and made it into Fedora 6. Still reading the thread to see if
there is a fix yet.


Chris Smith-16 wrote:
> On Tuesday 12 June 2007, Max Kipness wrote:
>>  Also some of the files names have pound signs and some file
>> names start with a number. The strange thing is that if I move all files
>> except for 47 of the files, I can do the 'ls' from linux. However, if I
>> add
>> the 48th file back to this directory I start getting the 'Invalid
>> Argument'
>> error again. I tested other directories with more than 48 files and never
>> get this error, so it has something to do with these files and having
>> more
>> than 48. I also moved the files to a different folder, and still had the
>> same error reading the new folder contents.
> Are all of the filenames valid in the Linux world?
> What happens if you use smbfs instead of cifs?
> If you copy all of the files to another folder and do a mass rename 
> substituting all non-alphanumeric characters with alphanumeric ones what 
> happens?
> Could it be a character encoding issue?
> Have you examined all of the mount.cifs options (man mount.cifs)?
> Chris
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

View this message in context: http://www.nabble.com/Invalid-Argument-ls-dir-mounted-share-tf3907351.html#a11127027
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list