[Samba] Multiple problems: installing SWAT, no longer access to a restored (after deletion) share, ACL inheritance

Any None sambaml at yahoo.de
Thu Jun 14 19:10:57 GMT 2007

I'm a job trainee, very new to Linux and Samba and was asked to set up a server based on OpenSUSE and Samba. The idea is not to make a production server but to investigate how and how well this works (the company is Windows exclusive at the moment)

I got as far as properly installing Linux and Samba 3 with the help of the guides on the OpenSUSE website. But there are a few things that still pose a problem. They're most likely due to my lack of knowledge and mistakes I made. But I would appreciate any pointers and help on the matter you can give me.

1. My understanding of ACL inheritance is that if this is 'on' for a share, any folder or file made under this share directory by the user would 'inherit' the ACL settings from the share folder. Yet this does not work at all, instead the create masks are applied. Did I interprete the meaning of the function wrongly, or is something else broken?

2. The Samba guide on OpenSUSE (at computerlanguages.org) says that to install SWAT, I need to enable among others smbfs and nfs in the System Services in YaST. When I try this I get the error '6: not configured'. Unfortunately the guide did not anticipate this. SWAT seems to work fine anyway. Is this the normal response? Both are listed as running: 'Yes*' in the basic view, but 'no' in the advanced view so I'm guessing they're not running at all. Can this cause problems, and how do I configure these so they will run?

3. In SWAT I accidentally deleted a share. No problem I thought, I'll just recreate it. I used the exact same settings (as described in the aforementioned guide) and recreated the share. It shows up on Windows clients but when I try to access it, I get the message I don't have access rights. I double checked the password and username, but they're OK. I checked the user still exists and is present in the Samba password file, also OK. Even root can't access this share. What has happened here? Is this a know behaviour when deleting and recreating the same share?

4. In another guide on the net I read that you can use SWAT on any PC in the network, taking care as traffic isn't encrypted. I tried from one of my Windows clients but all I get is a blank page. Do you need to especially activate this possibility somewhere? I checked the etc/services file as some guides say you have to enter swat 901/tcp there. This entry is listed but marked 'conflict' as there's already an entry for this port: smpnameres 901/tcp (and udp). Is this perhaps the cause? How do I go about to solve this conflict?

Sorry to dump so many questions on you in one go, but I've tried asking in a ng for some time now and am not getting responses as problems keep piling up. Any hint or tip would be great, thanks!


Jetzt Mails schnell in einem Vorschaufenster überfliegen. Dies und viel mehr bietet das  neue Yahoo! Mail .

More information about the samba mailing list