[Samba] Problem about samba3 on freebsd, with smbldap-tools

Cardon Denis denis.cardon at tranquilitsystems.com
Tue Jun 5 19:45:24 GMT 2007

Patrick Dung a écrit :
> Hi
> I have tried to setup freebsd (with samba3 ports), backend is openldap
> with smbldap-tools.
> After a windows client joined the domain, I tried to right click a
> folder to set Security/permission.
> The windows client has a popup windows which display:
> The program cannot open the required dialog box
> because it cannot determine whether the computer named "DOMAIN" is
> joined to a domain
> I have also tried to do same setup with Debian/Linux with the same
> settings in samba/openldap but it did not have this problem.

Have you check that the entry is correctly created into the ldap tree
(type smbldap-usershow DOMAIN\$ if DOMAIN is really your computer
name...). You should also check that the group id/SID of your computers
does exist in your ldap. When the windows box is joined to a domain, you
should get a log of the complete smbldap-useradd line used for adding
the computer in your smb.log file. If it failed, you can replay it on
the command line to see what is the error code. Perhaps there is a
missing perl library.

Hope this helps,


> BTW seems HPUX with the CIFS also get this problem:
> http://docs.hp.com/en/B8725-90119/ar01s05.html
> Any ideas?
> Thanks
> Patrick
> ____________________________________________________________________________________
> Building a website is a piece of cake. Yahoo! Small Business gives you all the tools to get online.
> http://smallbusiness.yahoo.com/webhosting 

Denis Cardon
Tranquil IT Systems
10 rue du Docteur Bouchard
49400 Saumur
tel : +33 (0)

More information about the samba mailing list