M Azer azermina at gmail.com
Mon Jan 15 16:04:16 GMT 2007

Hello all,

I am running samba-3.0.23c-2 on Redhat 3 enterprise as ADS. I am able to see
the windows users and groups with wbinfo.

[root at itbox /]# getent passwd windowuser

when i log to the network with one of the xp client machine i see home share
as well as a public share but i get access denied to both even after giving
the public share chmod 777 to everything on.

from the linux terminal i tried to:
[root at itbox /]# smbclient //itbox/windowuser -U windowuser

the second time I ran the same command i got:

[root at itbox /]# smbclient //itbox/windowuser -U windowuser
Domain=[CAD] OS=[Unix] Server=[Samba 3.0.23c-2]
tree connect failed: NT_STATUS_ACCESS_DENIED

all of my windows users are able to logon the linux termainl with their
windows username and password

        security = ADS
        workgroup = CAD
        realm = CAD.TESTDOMAIN
        netbios name = itbox
        preferred master = no
        password server =
        client use spnego = yes
        server signing = auto
        encrypt passwords = yes
        winbind separator = +
        idmap uid = 1000-20000
        idmap gid = 1000-20000
        winbind enum users = yes
        winbind enum groups = yes
        winbind use default domain = yes
        winbind cache time = 0
        winbind nested groups = yes
        template homedir = /home/%D/%U
        template shell = /bin/bash
        log file = /var/log/samba/%m.log
        log level = 3
        max log size= 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        hosts allow = 192.168.1. 192.168.0. 127.
        comment = Home Directories
        valid users = %S
        read only = No
        browseable = No
        path = /data
        public = yes
        writable = yes
        browseable = yes

More information about the samba mailing list