[Samba] access to data denied

Roland_Lepper at Liteonit.com Roland_Lepper at Liteonit.com
Thu Jan 11 14:19:44 GMT 2007

I've reinstalled my testserver again and found the problem.
It has something to do with samba-vscan.

With a fresh install (without samba-vscan, clamav running) I could access the mailbackups .nsf
After I configured samba-vscan and clamav and restarted samba, I'm getting this access denied error
when opening the mailbackup files.

Then i checked the samba-vscan conf file.
i changed the setting "deny access on error" from Yes to No and restarted all services.

This did the trick.

The mailbackups are pretty big, so clamd will skip them for scanning which resturns in an error for
samba-vscan and deny access to the mailbackupfile.

Best Regards,
Roland de Lepper

                      Roland_Lepper at Liteonit.com                                                                                                                                                   
                      Sent by:                                             To:       samba at lists.samba.org                                                                                         
                      samba-bounces+roland_lepper=liteonit.com at list        cc:                                                                                                                     
                      s.samba.org                                          Subject:  [Samba] access to data denied                                                                                 
                      11/01/2007 11:22                                                                                                                                                             

I have a standalone samba server for mailbackup purpose from Lotes Notes in a AD 2003 domain.
I've created one share which holds the mailbackup-folders of my users.

I've set the permissions on each folder so, that only users have access to their own mailbackup

drwxrwx- - - user1.root usersmailbackupfolder.

I can write a backup.nsf to the usersmailbackuop folder.

The permissions under the usersmailbackup folder:

-rwxrwx- - - user1.root mailbackup.nsf

The problem is that I can't open this mailbackup.nsf in lotus Notes anymore. I get a Access to data
denied error. Although user1 is owner of the mailbackup.nsf and user1 is logged in to Lotus Notes.
I even tried to change the permissions to 777 on the folder and the backupfiles, but that didn't
even worked out.

All operation (folder/files permissions) in Windows Explorer are working fine on the Samba share.

Is this Samba related or is this a specific Lotus issue?

ps. I can open the mailbackup.nsf if I copy the file to a Windows Share.

Please help.

Best Regards,
Roland de Lepper

To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list