[Samba] Joining Domain Issues

Matt Sellers indigoblu at gmail.com
Fri Jan 5 21:10:16 GMT 2007

Hello All,

I work with a large AD connecting a small number of linux boxes for our
school using a winbind/ldap for our university.

We have had relativly few issues but im haivng one now I cant seem to fix.

I recently brought up a new client and tried to join it to our domain but I
get the following error.


[2007/01/05 14:59:29, 10] libads/kerberos.c:kerberos_kinit_password_ext(89)
  kerberos_kinit_password: using MEMORY:cliconnect as ccache
[2007/01/05 14:59:29, 0] libsmb/cliconnect.c:cli_session_setup_spnego(785)
  Kinit failed: KDC reply did not match expectations
[2007/01/05 14:59:29, 3] libsmb/cliconnect.c:cli_session_setup(887)
  SPNEGO login failed: KDC reply did not match expectations
[2007/01/05 14:59:29, 1] libsmb/cliconnect.c:cli_full_connection(1523)
  failed session setup with NT_STATUS_OK
[2007/01/05 14:59:29, 1] utils/net.c:connect_to_ipc_krb5(255)
  Cannot connect to server using kerberos.  Error was NT_STATUS_UNSUCCESSFUL
[2007/01/05 14:59:29, 10] intl/lang_tdb.c:lang_tdb_init(138)
  lang_tdb_init: /usr/lib/samba/en_US.UTF-8.msg: No such file or directory
Failed to join domain!


I've also noticed that our machines that our current machines cannot
successfully join the domain but seem to still be working as they continue
to grab valid krb tickets from the AD server.

We are using the same krb5.conf/smb.conf configuration that has always
worked, the only recent change was an upgrade to 3.0.23d from 3.0.23c.

Please advise any debugging procedures as I would love to understand what
krb response the machine is getting and what it expects.

Matt Sellers

More information about the samba mailing list