[Samba] CIFS, Samba 3.0.23d and file locking

stefano at amti.com.br stefano at amti.com.br
Tue Jan 2 23:28:37 GMT 2007


I have a 16-bits Cobol program running at Novell 5.1.

I'm migrating the whole network (around 150 terminais) to Linux + LTS
processing DOSEMU into cluster and making a storage server just for data.

My surprise last week was that the smbfs client for Linux doesn't support
the file locking, after googling, found that a solution would be to use
CIFS instead SMB and upgrading the Samba version for 3.0.23D.

Ok, kernel patched (, CIFS working, Samba upgraded and running.

Now, when I map the share in data storage it is rightly mapped, using the
command (from samba 3.0.23d compilation):

mount.cifs // /data -o username=test,password=test

When I run the Cobol program (that mounted using smbfs works fine - just
don't lock the files, like windows client do correctly) it freezes right
after open the first screen, in syslog I get the log:

kernel:  CIFS VFS: Error unlocking previously locked range -37 during test
of lock
last message repeated 30 times

Tried to start the mouting with the nolock option but that's not recognized.

My system:
Slackware 11.0
Intel Dual Xeon 3.0 i386
Samba Version 3.0.23D
Kernel CIFS built-in compiled (patch 1.20, from samba.org)


More information about the samba mailing list