[Samba] Solaris 9 Samba 3.0.24

Travis Knabe knabet at wou.edu
Wed Feb 21 23:08:30 GMT 2007

I'm currently running samba 3.0.20a

I can configure and make 3.0.20a with no problem

I run the same configure command on the 3.0.24 source, configure works 
fine, but make returns the following.

( and just to test if a patch screwed me up I tested configuring and 
making the 3.0.20a version again, and it worked as it should )

Any bugs with 3.0.24???

-I/a1/samba/builds/samba-3.0.24/source/iniparser/src -Iinclude 
-I/a1/samba/builds/samba-3.0.24/source/tdb  -I. -DHAVE_CONFIG_H  
-DLDAP_DEPRECATED -DSUNOS5 -I/a1/samba/builds/samba-3.0.24/source 
      LIBS = -lsendfile -lresolv -lnsl -lsocket -ldl
      LDSHFLAGS = -G  -lthread
      LDFLAGS = -lthread
      PIE_CFLAGS =
Compiling dynconfig.c
In file included from include/includes.h:1067,
                 from /a1/samba/builds/samba-3.0.24/source/dynconfig.c:21:
include/proto.h:1:1: unterminated #ifndef
*** Error code 1
make: Fatal error: Command failed for target `dynconfig.o'

Travis Knabe
Assistant Director 
Computing Services
Western Oregon University

More information about the samba mailing list