[Samba] Vista (pre-installed OEM editions) creating new files or folders on network shares

Graeme Perkes agentmaximus at gmail.com
Wed Feb 21 10:36:46 GMT 2007

Hi Jeremy,

I compiled up that patchset but then came to the conclusion that the 
cause of the problem was the installation of Vista itself. Normally I 
use a Linux box as a WINS server but to isolate the problem I made an XP 
box on the network the WINS server.  To make sure samba wasn't the 
playing a role I then tried access to shares on remote XP and remote 
Vista drives from the problematic Vista clients.

Since then I have reported the problem to the OEM and the retailer. The 
OEM was originally not very helpful. The retailer has reproduced that 
problem with the particular brand of hardware from their shelf stock. 
The OEM is paying much more attention to the problem. I'm not sure if a 
rather large software company is also involved.

A number of big hardware vendors may have this problem in their OEM 
Vista installations supplied on new PCs / laptops. I don't know if all 
hardware vendors are affected.  Read the forum link posted below for 
hints at the hardware vendors affected ...



Jeremy Allison wrote:
> On Sat, Feb 17, 2007 at 08:59:09PM +1100, Graeme Perkes wrote:
>> Hi,
>> This post is to prevent other people that are having trouble with Vista
>> clients from going down a blind alley investigating problems in their samba
>> configurations.
>> After some research I have found (see link below) that there is a general
>> problem for pre-installed OEM editions of Vista Business (and possibly other
>> vista versions) in creating files and folders on network shares.
>> The problem presents itself on the Vista clients when navigating into a
>> network share (Linux or XP-based share) and trying to create a new folder.
>> These are the steps
>> 1. In Vista OEM client right click in open folder on share
>> 2. Select "Create -> New -> Folder"
>> 3. Vista will automatically create a new folder called "New Folder"
>> 4. On attempting to rename the folder to a more sensible name, an error
>> dialog pops up and says 'The "\\..." folder does not exist. The file may
>> have been moved or deleted.
>> Given my network shares are samba based I initially investigated
>> incompatibilities in my older samba 3.0.20a WINS / fileserver. I have
>> installed samba 3.0.24 with latest patches on a test server and I am still
>> experiencing the problem.
>> I found the following forum thread about the issue.
>> http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=522208&SiteID=17&PageID=0
>> The current solution is to perform a clean install of Vista rather than
>> cloning an existing installation (which seems to be the way OEM systems are
>> built). I unfortunately don't have this option since the two new Acer Vista
>> clients we purchased did not come with Vista install CDs.
>> I'd be interested to hear if anyone has been able to resolve this issue
>> without reinstalling Vista.
> Have you tried using the Vista patchset we prepared a 
> week or so ago ? You shouldn't see this problem with
> that code.
> Cheers,
> 	Jeremy.

More information about the samba mailing list