[Samba] Howto setup printing with Windows XP Clients, cups and samba..

Dale Schroeder dale at BriannasSaladDressing.com
Fri Feb 9 18:32:45 GMT 2007


I can't remember if you posted your Samba version or not.  If you are 
using a Samba version between 3.0.11 and 3.0.22, you will need to add 
"enable privileges = Yes" to the global section.  The default was 
changed from No to Yes in 3.0.23.  If this isn't the issue, I'm running 
out of ideas.  Also, see link at bottom of post for cupsaddsmb/adobe 
driver problem.


schönfeld / in-medias-res.com wrote:
> Hi,
> okay. With your help I'm a step further, but the problem itself
> persists. In fact something must have gone wrong, when i added PrintOP
> privileges to the admin user, cause it didn't have the flags I've added.
> Now the Admin User does have the necessary privileges:
> majestix-linux:~# net -U Administrator rpc rights list Administrator
> [2007/02/09 11:28:30, 0] param/loadparm.c:map_parameter(2698)
>   Unknown parameter encountered: "privileges"
> [2007/02/09 11:28:30, 0] param/loadparm.c:lp_do_parameter(3428)
>   Ignoring unknown parameter "privileges"
> Password:
> SeMachineAccountPrivilege
> SeTakeOwnershipPrivilege
> SeRemoteShutdownPrivilege
> SePrintOperatorPrivilege
> SeAddUsersPrivilege
> SeDiskOperatorPrivilege
> The user is in the right group to be a Domain Admin. SID of the Domain
> Admins group is correct. Writing to the print$ share is possible.
> What else could be the problem?
> Patrick
> schönfeld / in-medias-res.com wrote:
>> Hi Dale,
>> Hi Martin,
>> thanks for your good explanations. I will try to follow them in order to
>> get driver upload working properly.
>> Thanks and best Regards
>> Patrick
>> Dale Schroeder wrote:
>>> Don't forget to enable the privilege to add printers as described in 
>>> http://us1.samba.org/samba/docs/man/Samba-HOWTO-Collection/rights.html#id341486
>>> .  Required for cupsaddsmb with postscript drivers, or to directly
>>> upload windows drivers to a raw CUPS queue.
>>> Dale
>>> Martin Zielinski wrote:
>>>> Hi,
>>>> That's really not the way you should do this.
>>>> Try this:
>>>> 1st Check your permissions :
>>>> Enter on your windows client: Start->Run-> \\<server>\print$
>>>> (Note the $)
>>>> You should see at least the W32X86 folder you previously created in
>>>> the driver section of your Samba server.
>>>> Try to add a new folder - or (if exists) change into W32X86\3 and create
>>>> a file (or folder) *from your windows client*.
>>>> If this fails - you have a permission problem and have to solve it first.
>>>> 2nd Install your driver:
>>>> - Enter on your windows client: Start->Run-> \\<server>
>>>> - Change into the "Printers and Faxes" folder
>>>> - Right click -> Server Properties
>>>> - Middle tab "Drivers"
>>>> - Click "Add" and follow the instructions
>>>> 3rd Assign your driver:
>>>> - In the "printers and faxes" folder right-click on a printer
>>>> - Select Properties
>>>> - Tab "Advanced"
>>>> - Select the driver from the drop down box
>>>> - Ok
>>>> Your done.
>>>> Most problems with permissions will be caused because of the unix
>>>> rights of your driver directories.
>>>> You could try to "chmod 0777" them all "e.g. /var/drivers
>>>> /var/driver/W32X86 ..."
>>>> Hope that helps,
>>>> Martin
    Hi there,
    > slowly but sure I'm getting absolutely *insane* with the
    > printer setup on a *Samba* PDC. I got Cups to work. It works
    > like a charm if someone *installs* a printer via the cups
    > *interface*. It also prints *in* a good quality. On *Samba* side I
    > even have those "Printers and fax devices" *in* the visible
    > shares. And if i *install* CUPS6 Drivers manual on the target
    > system i can even print on the printers *in* there. Everything good.
    > But how do i get drivers uploaded to my *samba*, so that it
    > works to download them automatically on the clients. And
    > which drivers should i take? I've tried to add the cups
    > drivers with cupsaddsmb, but that fails because this util is
    > searching for adobe postscript drivers.**

**You can use MS postscript files: ps5ui.dll, pscript.hlp, pscript ntf, 
and pscript5.dll.
They can be copied from any Windows machine that has a postscript 
printer installed.
See:  http://www.cups.org/doc-1.2/man-cupsaddsmb.html .

    > I then tried to  *install* the adobe postscript drivers, but it's 
hard to find a
    > package which can be extracted just like it is and it is even
    > harder to find out what these damn .exe does *install*.
    > Then: I searched those files, that cupsaddsmb is accessing on
    > a windows xp system and *installed* them to cupsaddsmb's source
    > folder. That worked for running it successful. I'm also able
    > to connect windows xp printers,
    >   but printing is a catastrophe. It's like someone has thrown
    > the letters *in* a random order on the paper.
    > I also tried to *install* drivers by usage of the (Domain-)
    > Administrator account on a windows xp system, but i keep
    > getting messages that i do not have the permission to do so :-(
    > What do i do wrong?
    > See testparm output below.
    > Greets and Thanks *in* advance
    > Patrick

More information about the samba mailing list