[Samba] Connection dropped when copying large files to a SambaServer

Michelle Dupuis support at ocg.ca
Thu Feb 8 19:04:18 GMT 2007

I can see h/w being a cause in many cases.  We've reproduced this on 2
different servers with 2 different storage technologies.  And once using
Backup Exec and once using Ghost.

Starting to smell a lot like a s/w problem...


-----Original Message-----
From: Michael Gasch [mailto:michael.gasch at eva.mpg.de] 
Sent: Wednesday, February 07, 2007 11:49 PM
To: Michelle Dupuis
Cc: samba at lists.samba.org
Subject: Re: [Samba] Connection dropped when copying large files to a


just to tell you that we had the same issue 2 years ago and my colleague
blamed samba for this. in fact it turned out to be a SCSI HW problem on the
system. all stress test on the local storage succeeded but when samba came
into the game it broke the system. that's why we thought it's related to
samba, which wasn't true...


Michelle Dupuis wrote:
> Not hijacking the thread here...just adding more info as I have the 
> same issue.
> I run Samba 3.0.23c (on FC6 64 bit), and am backing up from a Windows 
> box to my Samba share.  Sometimes it works great; other times the 
> samba share locks up (I need to restart the smb service); and last 
> week samba caused a kernel panic.  I can sometimes get 65GB onto the share
before it locks up.
> I can backup to the share using NFS (using Windows Services for Unix) 
> without issue, but not to Samba.  My relevant smb.conf settings are:
> reset on zero vc = yes
> read raw = yes
> socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
> Strangely, smb logs NO errors!  Trying to browse to the share from any 
> windows client times out.  But, after an smb restart everything is 
> fine again.
> -MD-
> -----Original Message-----
> From: samba-bounces+support=ocg.ca at lists.samba.org
> [mailto:samba-bounces+support=ocg.ca at lists.samba.org] On Behalf Of 
> Felipe Augusto van de Wiel
> Sent: Monday, February 05, 2007 9:05 AM
> To: samba at lists.samba.org
> Subject: Re: [Samba] Connection dropped when copying large files to a 
> SambaServer
> Hash: SHA1
> On 01/30/2007 02:44 PM, mactek - Manuel Teixeira wrote:
>> Hi all
>> I have a CentOS 4.4
>> Kernel 2.6.9-11.EL
>> Samba (smbd -V)
>> 3.0.10-1.4E.9
> 	As a side note, you _really_ should install a newer version of
> the last stable release is 3.0.23d.
>> I've been using this server as a small file server recently i needed 
>> to do a backup (ntbackup to file) and the backup fails randomly, the 
>> largest backup file i managed was about 3GBytes I tried copying large 
>> files and randomly the connection is lost I tried with a ping at the 
>> same time and the replies don't get interrupted so it seems to me it 
>> is a samba issue
>> I have the latest versions (except the kernel) or so the updater 
>> tells me
> 	If you are talking about samba then, no, definetely you don't have 
> the latest version. Could you please post your smb.conf so the list 
> can take a look at it?
> 	Good tips would include to check the oplocks and the socket options.
>> thanks all
>> Manuel Teixeira
> 	Kind regards,
> - --
> Felipe Augusto van de Wiel <felipe at paranacidade.org.br> Coordenadoria 
> de Tecnologia da Informação (CTI) - SEDU/PARANACIDADE
> http://www.paranacidade.org.br/           Phone: (+55 41 3350 3300)
> Version: GnuPG v1.4.6 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> iD8DBQFFxzl6Cj65ZxU4gPQRAiyiAJ9yLZrnR2fPG4Dk5Km3ATVEIgnw+ACgphJk
> LhmgDczhEI+NjnEJzmozc2g=
> =lgWl
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list