[Samba] Reference Documentation Server

- Reyneke reynekejunk at hotmail.com
Tue Feb 6 14:42:35 GMT 2007

> > I'm trying to get samba (v3.0.23d) going on an embedded system.

>Try to remove this line if you don't want any kind of security
> > passdb backend = guest

Tried that, no difference. Also tried this:

>security = user
>map to guest = bad password

Same deal. Using smbclient and I get the following:

smbclient -L localhost -U%  = OK
smbclient -L localhost -Ux%  = OK
smbclient -L localhost -Ux%x  =  NT_STATUS_LOGON_FAILURE
smbclient -L localhost -U%x  =  OK

(x = nonexistent test credentials)

Any time a password & user is set it fails.

Single user [samba] added to system. Shared folder is word readable and 
owned by user samba. Service [smbd -D] kicked off by root.

Could it be client domain related? Unix passwd setup (although I thought 
this is suppose to be irrelevant with this setup - I've added the etc/passwd 
file)? Any shared libs that might be missing? What about smbpasswd?

~~~~~~~~~~~~~ etc/passwd ~~~~~~~~~~~~

samba:x:500:500:Samba User,,,:/home/samba:/bin/sh

Click Here To Find Your Perfect Match This Valentines!  

More information about the samba mailing list