[Samba] Urgent help request!

Elio Tondo elio at tondo.it
Mon Feb 5 21:18:01 GMT 2007

From: "Michael St. Laurent" <mikes at hartwellcorp.com>

> I've gone further down the food chain in diagnosing the problem:
> A net rpc join command works but wbinfo -u or wbinfo -g fails:
> ...
> I've tried removing the server from the domain and rejoining it to no avail.
> The domain has a Windows ADS controller running in mixed-mode.


I don't know if this can help, but you can find attached a post I sent
some months ago, that had no reply so far on the list. Basically,
I had to switch to ADS mode for the same problem you have, and
that worked for some time, but then, after a Samba release update,
it stopped working (and the situation is the same with the current
release). Older Samba versions work well in ADS mode with
exactly the same Win2000 server.

I managed to compile both the working and the failing version from
sources, and I tried some debugging, but without any detailed
knowledge of the sources I only managed to narrow down the
problem to  something related to the LDAP connection to the ADS
server; maybe some hint about the debugging process could help.


More information about the samba mailing list